0

I have an iPhone 5 that I tried to restore iOS 10.3.3 to. I have made sure that the .ipsw file matches the phone, and have updated iTunes.

In iTunes, I get this error when I try to restore or update (to) iOS 10.3.3:

enter image description here

In iMazing, I get this error when I try to restore iOS 10.3.3:

Cannot restore iPhone 5.

Error Domain=com.apple.MobileDevice.MobileRestore Code=-1 
"AMRestorePerformRestoreModeRestoreWithError failed with error: -1"
UserInfo={NSLocalizedDescription=AMRestorePerformRestoreModeRestoreWithError failed with error: -1, NSUnderlyingError=0x60800164ec10 {Error Domain=AMRestoreErrorDomain Code=-1 "Failed to handle message type StatusMsg" UserInfo={NSDescription=Failed to handle message type StatusMsg, NSUnderlyingError=0x6000012584e0 {Error Domain=AMRestoreErrorDomain Code=-1 "failed to update device firmware" UserInfo={NSDescription=failed to update device firmware, NSUnderlyingError=0x60000124b370 {Error Domain=AMRestoreErrorDomain Code=-1 "ramrod firmware update failed" UserInfo=0x600000278280 (not displayed)}}}}}}

In Joyoshare iPasscode Unlocker, I get this error: Unlock Failed! Please confirm whether the firmware matches your device model.

On iTunes and Joyoshare iPasscode Unlocker, I have tried with the app downloading the firmware from apple.

On iTunes and iMazing, I have tried with the app using firmware I downloaded from apple. (I tried both ways on iTunes)

Does anyone know how I can restore any version of iOS so I can use this phone? I expect them to turn me down though, as I have a third-party battery and screen (the battery got replaced by a third-party one because of water damage, and I replaced the screen w/ a third-party one because it was cracked).

Edit: I just went to apple, they tried restoring it with iTunes, and they got the same error. Apparently anything could be the problem.

The firmware is from ipsw.me, which provides links to apple's ipsw downloads.

You must log in to answer this question.

Browse other questions tagged .