On a clean install of 10.14.5: Multiple reports of the beta version not working using a headless install: https://github.com/Homebrew/install/issues/206

This lead me to trying to manually do a headless install. I tried all of the various methods in How can I install the Command Line Tools completely from the command line? and none of them show anything but:

Mac-mini:~ anka$ /usr/sbin/softwareupdate -l | grep "\*"
 * MacBook Pro Supplemental Update-

Yet, I can xcode-select --install and it allows me to install it.

Anyone know how to get it to show up in softwareupdate -l so we can headless install it?

  • You can still remote in to a headless Mac so you can get the console session and accept the install prompt. But I’m guessing you want this over ssh or have other reasons to say headless. Leaving this here in case someone just needs to get it going now.
    – bmike
    Commented Jun 6, 2019 at 0:55

1 Answer 1


Apple looks to have fixed it. I had submitted a bug report, but I'm not sure if that helped or not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .