1

This question already has an answer here:

Yesterday I ran the system update and mistakenly installed Command Line Tools for Xcode 11 beta 1 in a system running macOS Mojave.

This update is breaking some of my dev applications. I would like to downgrade back to the current public release of Command Line Tools for macOS Mojave 10.14/Xcode 10.2.1.

How do I uninstall them? Is it possible to do without uninstalling Xcode?

I am running macOS Mojave 10.14.5 with Xcode 10.2.1.

➜ ls -l /Library/Developer                 
total 0
drwxr-xr-x 6 root 192 Jun  5 10:08 CommandLineTools
drwxr-xr-x 4 root 128 Apr 23 11:39 PrivateFrameworks
➜ ls -l /Library/Developer/CommandLineTools
total 0
drwxr-xr-x 5 root 160 Apr  6 02:30 Library
drwxr-xr-x 3 root  96 Apr  6 01:55 Packages
drwxr-xr-x 4 root 128 Jun  5 10:09 SDKs
drwxr-xr-x 7 root 224 Apr  6 02:30 usr

Update:

So it seems that the beta version of the CLTools are messing something up in the mono library. As all mono applications are crashing. Tried different applications build with mono.

I tried the remove instructions and also completely uninstalled / reinstalled xcode.

However, the issue is still the same. All mono applications are crashing!

marked as duplicate by grg Jun 5 at 8:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to Ask Different :) Can you share the output of running ls -l /Library/Developer and ls -l /Library/Developer/CommandLineTools? – Nimesh Neema Jun 5 at 8:10
  • Sure, updated my initial post. – Jakub Juszczak Jun 5 at 8:16
  • You can go through the linked duplicate to find instructions on how to remove the beta Command Line Tools. – Nimesh Neema Jun 5 at 8:19
  • The instructions do not help. As it seems that they do not remove everything. I tried the instructions. I also completely removed xcode and reinstalled it. But applications are still crashing. – Jakub Juszczak Jun 6 at 9:40

Browse other questions tagged .