Whenever I connect my iPhone to my MacBook using the USB cord, the Web browsers on my iPhone stops working. I can't browse the web using Safari or Chrome. However, I can still surf Instagram without any problems.

Another weird thing I notice is that the Wi-Fi symbol turns into LTE when I connect to my MacBook.

However, once I disconnect the cable, the Wi-Fi symbol comes back. If I refresh the page on either Chrome or Safari it loads.

What is going on?

I don’t have a Personal Hotspot section under Settings app:

When my cellular data is shut off, neither LTE nor WiFi show up: enter image description here

Also noticed that the iOS Stack Overflow app does not work either when connected to my MacBook.

  • On your iPhone go to Settings app → Personal Hotspot and see if the Personal Hotspot is turned on. Try turning it off and see if that fixes the issue. If it reoccurs, try turning off mobile data from Settings app → Mobile Data and see if that fixes the issue.
    – Nimesh Neema
    Jun 3, 2019 at 15:21
  • Hi @NimeshNeema , I updated my question with a screenshot. I don’t have a personal hotspot section so I don’t think it’s turned on?
    – bigpotato
    Jun 3, 2019 at 15:26
  • What about under Cellular? Is the mobile data turned on?
    – Nimesh Neema
    Jun 3, 2019 at 15:41
  • @NimeshNeema Yes Cellular Data is turned on
    – bigpotato
    Jun 3, 2019 at 15:42
  • Try by turning it off while keeping your iPhone connected to Wi-Fi.
    – Nimesh Neema
    Jun 3, 2019 at 15:43

1 Answer 1


As OP said, "Internet sharing is on and all the sub-boxes are checked", I think this is the problem.

Not all apps in iOS can detect and use network coming through iPhone USB. Most of them check only Cellular data, Wi-Fi and Bluetooth for internet

On Mac System Preferences -> Sharing, Internet Sharing by USB cable should be turned off for using iPhone apps.

  • 1
    You were spot on!!! After turning off internet sharing, I now see the Wifi symbol again even when connected by USB. And my browsers work too! Thanks so much!
    – bigpotato
    Jun 4, 2019 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .