1

At random times Apple Mail rejects the current stored passwords for my gmail accounts. When I go into Preferences>Accounts>Server Settings, the windows that are supposed to appear to change or update the passwords for incoming and outgoing mail simply are not there!!! How do I update or change the passwords, then, in Apple Mail so that I can have my emails appear properly, as they do when there is no password issue being created by the site itself?

I found this unanswered question at discussions.apple.com: The link for the apple.com post

The link for the tigertech post that gives detailed instructions in fixing password issues

Behaviour Shown

A screen shot of the tigertech post that shows what the Preferences>Accounts>Server Settings window is supposed to display

Expected Behaviour

  • Please add a screenshot. – ankii Jun 3 at 5:11
  • Can you reproduce this with a new user account (make a new account in system preferences) and then add one and only one problematic account? The obvious issue would be that you have entered the same account twice or keychain has one item attached to two log in or is missing an entry. Rather than asking you to check all that, it's far simpler to isolate the user account IMO. – bmike Jun 4 at 11:39
  • @bmike There is no issue. Google and iCloud accounts do not allow editing server settings. Institute or outlook account etc allow changing these settings. – ankii Jun 4 at 15:58
1

Welcome to Apple.SE JONAllow. What you're seeing in the mail app is the expected behaviour of the mail app. Both of the screenshot are of two different conditions i.e. Gmail and Company account.

Gmail doesn't allow server settings to be changed via Mail.app Preferences pane. While, accounts such as of an institute of study or work have to be configured in server settings via said pane.

So to change passwords, I suggest going to Mac Preferences -> Internet Accounts, select the said account, click "-" in the bottom. And add it back.

IMAP mailbox will not pose any problem restoring all mails. It might take time though.

One unverified alternative is that you see the sidebar in the mail and find a

error sign

error sign. Tap on it and see if it gives other options like "Try again" and hope for a password reset prompt. You might see "System Preferences want to use google.com". Allow it.

Hope it helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .