Just wiped my hard drive on my MacBook Pro from 2013. Went to install a new copy of MacOS Sierra. I get the following error:


I looked online and tried change the date using the Utility Terminal and the following command:

date mmddHHMMyy

Then did

csrutil enable
csrutil clear

Then I tried clearing the NVRAM using command + option + P + R on startup.

Still no luck. Still getting the same error message. Apple support told me to go to a "computer repair store".

Any advice?

  • When/how exactly was the error displayed? Just text on a black screen, a dialog box or something else?
    – nohillside
    Commented Jun 3, 2019 at 18:59
  • It was displayed as a dialogue box. It gave me the option to "cancel" or "retry". If I clicked "retry", it just popped up against after a few seconds. Commented Jun 4, 2019 at 0:16
  • Did you reinstall from Recovery? If not, where did you get the Sierra installer from?
    – nohillside
    Commented Jun 4, 2019 at 5:13
  • So when I'm trying to re-install, it asks me which hard drive I want to install to. There are two hard drives that are pictures, on the left is my standard MacIntosh HD. On the right is "Recovery HD" which is greyed out. When I hover over "Recovery HD", it says that it is locked. It seems that when I'm trying to re-install to MacIntosh HD, it's trying to access the Apple Store to download a copy of Sierra. Sierra was my original OS. But somehow the installer is having trouble authenticating that I actually own a copy of Sierra. I'm going to try and create a bootable USB and boot from that. Commented Jun 5, 2019 at 21:56
  • Is there a way to select where you are access your copy of Sierra? Like would the Recovery partition have a copy of Sierra on it? Commented Jun 5, 2019 at 21:57

3 Answers 3


I had the same problem with my Macbook Pro mid 2010. I tried everything, but Sierra installation allways crashed with AMD-Action:downloadProduct:SP error. Then I created install USB with OSX Mountain Lion and it worked flawlessly. I upgraded to Sierra later via App Store.


I had the same. Just Re-install iTunes

  • 1
    Perhaps you need to expand on this a bit. The OP is trying to install the OS, not iTunes.
    – Allan
    Commented Oct 6, 2020 at 17:51

In my case the reason here was that my home directory is not on the primary volume. If you’re in such a situation you can easily fix that by creating a new folder (/Users/Shared) which will be located on the primary volume. Give it access to everyone, and voila it will work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .