0

Whenever I type a word with an apostrophe inside a note that I insert in a PDF document in Preview (i.e. "I'm"), the apostrophe automatically becomes a double-byte character. I have no idea why this is happening, nor how to fix it. I'm using Mac OS Mojave 10.14.5

Anybody have an answer on how to fix this?

1

That's the "smart quotes" feature converting the plain ASCII quote to a fancy (curved) Unicode quote (which is two bytes in UTF-8 encoding). You can turn this off with System Preferences -> Keyboard pane -> Text tab -> deselect "Use smart quotes and dashes". Note that this is a system-wide setting, so it'll affect most word processors as well as Preview.

  • Well, I will try what you suggest, but the odd thing is: it's only happening here, no place else, so that's why it seems odd to me, but I'll try it; thank you! – David Hal Chester Jun 2 at 7:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .