2

I see somebody already asked same question but I couldn't find a answer, so I am asking it again and will provide as detail as possible information.

I am helping a friend to reinstall OS X on his MacBook Pro. enter image description here

The laptop is Macbook Pro , model A1278, purchased around 2010.

I can enter Disk Utility and see it has a 240G disk, and a "Apple disk Image", I assume it's the factory reinstallation image.

The harddrive was partitioned as two partitions, one for Mac and one for Windows. My friend still want to keep the Windows partition ( Bootcamp), so I will not reformat the whole disk.

I have tried following steps:

  1. erase/reformated the partition ( the "empty" one ).

  2. Boot from Cmd-R , then "Reinstall MacOS". the result is "This is not a supported method of installing the operating system” enter image description here It showed "El Capitan", so I guess the factory image is El Capitan.

  3. Downloaded a El Capitan ISO, created a Boot-able USB key from it ( using Windows application TransMac ). Booted machine with "Option" key pressed, selected to boot from USB ( the Kingston disk), then "Reinstall MacOS". Got exact same "This is not a supported method of installing the operating system”.

  4. Booted with Cmd-Option-R, it showed "Starting Internet Recovery,This may take a while.". Seems working OK, but then got "The recovery server could not be contacted" .enter image description here

I have tried with WIFI connection and Ethernet connection, both with same error. Since it showed "High Sierra" logo, the Internet was working before it enter the real installation step.

It looks like as soon as the system start to install the OS, the network interface is disabled somehow.

I tried to entered terminal, I can see there is no IP on the en0 NIC. I even tried to use command line to configure a static IP on en0 and setup default route, then I can ping public IP like 4.2.2.2, but I couldn't get DNS configured under the terminal.

networksetup command is not available under the recovery terminal.

scutil command is available, but "list" command doesn't show en0 or WIFI interface at all, so I can't add a DNS configuration. Tried to manually edit "/etc/resolv.conf" , doesn't work. enter image description here

Now I am totally stuck. I am familiar with Windows/Linux but not a Mac guy, not sure what could be the problem. Would appreciate any suggestion.

Update: Turned out the USB disk restored by TransMac doesn't really work ( I thought I booted the system from USB, but only realized late it was the recovery partition, so no wonder it showed exact same error). But in Disk utility, it does recognize the USB disk and shows it has OS X Base installation.

Finally setup a Linux VM and used old good dd to copy the iso to USB key and it worked. I was able to boot from the USB and installed El Capitan, but then when the OS first start up, it stuck at here: enter image description here

The reason I was asked to reinstall the system was it won't boot and always stuck at exact same place. Now I have re-formatted the partition, reinstalled El-Capitan, but seems went back to exactly where it was.

Thanks, Jack

  • The current status is I was able to format/reinstall El Capitan, but when it boot, it stuck at the last point of the progress bar. This is the same behavior before I reinstall the OS. Tried to reinstall it with High Sierra, it started to install but failed with error "an error occurred while preparing the installation. Try running this application again" . I have updated the date to be accurate. Now I guess maybe there is some hardware problem, but Windows OS is working fine. – jack.chen.job Jun 3 '19 at 16:03
1

Update:

Tried Internet Recovery and still couldn't get Internet work in Terminal ( can't setup DNS, /etc/hosts file is on a readonly filesystem).

I went back to to try every boot key options I can find online, and Cmd-opt-PR to reset NVRAM fixed it.

| improve this answer | |
  • after NVRAM is reset, the system was able to boot into the El Capitan system I reinstalled; I then tried Internet Recovery to reinstall it as High Sierra, also worked. Interesting when the NVRAM was corrupt, I need to join the WIFI network with password when I start Internet recovery. When NVRAM is fixed, it remember the previous set WIFI credential. So Apple save WIFI credential in NVRAM, and it should be a clue NVRAM is corrupted if you need to rejoin the WIFI again and again. – jack.chen.job Jun 6 '19 at 18:26
0

You should boot with Cmd-R, then use the Disk Utility available via the menu to reformat the Mac partition. Then reinstall MacOS from there.

If you still get a 'server can not be contacted', others have reported that this can be due to a time mismatch, and to try to update the local time on the laptop by typing this into Terminal:

ntpdate -u time.apple.com

Then try the reinstall command again.

Others report that resetting the Hosts file helps, however, if you followed the above there is no hosts file, aside from what is in hidden boot partition, which is not likely to have been edited.

| improve this answer | |
  • There is no Internet when I am able to enter terminal, so ntpdate won't work for me. I did manually adjust the time by date and made sure it's close enough to real time in (difference less than 1second ), didn't help. – jack.chen.job Jun 3 '19 at 15:58
  • 1
    I suppose if there is no internet at the cmd line, then thats your first problem: you don't have a network. It's the same network service. You can configure your network in the Cmd+R area (you can't use Terminal tho?) – cmason Jun 3 '19 at 17:03
  • Hardware wise, WIFI and Ethernet NIC is fine. I can boot into Internet Recovery mode, either with WIFI or Ethernet connection, and the system will show High Sierra logo. But as soon as it enter the recovery mode, there is no Internet. WIFI is gray and I can't turn it on. Ethernet wise I can enter terminal and run "ifconfig en0 192.168.xx.xx 255.255.255.0" to assign it a static IP, run "route" to set the default route, then I can ping public IP. But I don't see any way to setup DNS in terminal. If I know the dns for apple recovery server, maybe I can try to add it into /etc/hosts. – jack.chen.job Jun 4 '19 at 12:49
  • support.apple.com/en-ca/HT202481 shows osrecovery.apple.com and oscdn.apple.com , I will give it a try later, see if it work. – jack.chen.job Jun 4 '19 at 12:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .