15

I have mail app open in background i.e. no window open. A new window randomly pops up without any conscious trigger by me. No new mail would have come.

Once it happened while I was in full screen mode of another app and the mail app split the window in half and got opened. This happens even when I am working in non Full-screen mode.

I presume that it has connection with notifications but other reasons are also welcome.

Once, it popped up above other apps, and some accounts were transitioning from offline to online state. I cannot confirm about Google account as one answer mentions.

Why might this happen but more importantly, how to stop this other than quitting it properly? I want to stop it from opening it altogether, not only in split view.


The answer to Mail opens a window randomly in split screen with my fullscreen window recommends to untick a Mail preference. Unfortunately I get the behaviour even thought the preference is unticked, so I look for other solutions.

  • 1
    I do not have an solution to this problem, but I have noticed that it seems to occur when one of my Google accounts briefly fails to connect (this happens from time to time). Has anyone else noticed this as well? – jchaselubitz Aug 2 at 14:15
  • 1
    Yes, yesterday, it popped above other apps, and some accounts were going from offline to online state. I cannot confirm Google specifically. – ankiiiiiii Aug 7 at 6:50
5

This was happening to me for a while, and it became very annoying. I found that if I force closed it and turned the laptop off and on, it worked. If that continues to happen, turn off the WIFI connection and do the same steps.

As to stop the behaviour in split mode, unchecking the checkbox in mail preferences for "Prefer split view while opening messages in full screen view" helps.

  • 1
    If we force quit or even quit the app, I also presume that it should stop causing trouble. But as you might understand, and I wrote in the question too, I need the app open due to 1. speed of sharing, 2. real time notifications, 3. to prevent sudden surges in energy while opening the app so many times in the day. I am not sure about turn off laptop and on, and since the trouble is not reproducible, I cannot check it. – ankiiiiiii Jun 3 at 20:32
4

I have been suffering from this problem for months. I tried so many solutions (for example https://www.reddit.com/r/MacOS/comments/7d81ak/solution_for_those_who_have_the_mail_app_randomly/ ) and so on.

This really irritates when I am watching a movie in fullscreen and the Mail app pops up randomly and splits the screen.

Possible workarounds: - Turn off desktop notifications as suggested by @Casimir - Turn off the split window of Mail when full screen (Prevent Mail.app from opening in split view)

In the end, nothing worked for me.

Temporary workarounds:
- Keep Mail app opening and make the window very small all the time. - Open multiple windows and keep Mail window open in one of the windows. - Also, If you can hide Mail.App by Cmd H or click on Mail at top left of you desktop, click Hide menu.

I suspect this bug is due to mail.app checking new emails periodically and each time wanting to be fullscreen. I have also added my vote on apple service and still waiting for a permanent solution.

Update
As suggested in comments by OP hiding the Mail.app (cmd h) is also an alternative, but still, we have to open the app all the time whenever we are running the computer so as not to be offended by intermittent apperance of Mail.app.

  • yes I understand. If you'd like to add, include cmd + h also as a workaround. Which vote btw ? – ankiiiiiii Jun 16 at 5:54
  • @ankiiiiiii vote means add your +1 to the questions in the Apple product forum such as discussions.apple.com/thread/7540901 or create your own new questions. – astro123 Jun 16 at 11:57
2

I've been experiencing this issue for a week now. The mail app pops up by itself in split view next to my full-screen browser several times a day. It hasn't happened in over a day now after following the steps in this reddit post according to which the culprit may be Google calendar. If you're using it, try changing the notification settings as follows:

  1. Login to Google Calendar at https://calendar.google.com.
  2. Click the settings gear icon (upper right-hand corner) and select “Settings” from the drop-down menu.
  3. Under the "General" tab (open by default), scroll down to "Event settings".
  4. Open the "Notifications" drop-down and switch from "Desktop notifications" to "Off" ("Alerts" might work as well).
  • By notifications in the question, I meant some mail notification triggering it, not calendar. I don't see any connection but I will give it a try. – ankiiiiiii Jun 2 at 15:15
  • 1
    This is a problem that's been coming and going for years. I haven't experienced it with Mojave before 10.14.5, but now it's back with a vengeance. And the trick with Google Calendars, which worked in the past, is not useful this time. I have completely deconfigured any use of Google Calendar, but my Mail still keeps on opening by itself. – wjv Jun 5 at 10:21
  • @wjv if my problem persists, I will revoke the answer acceptance. Right now it has stopped and the other answer despite having more votes(most probably by users which did the same) suggests a troubling approach. If you find a solution, please do answer it here. – ankiiiiiii Jun 6 at 15:52
  • 1
    I've just applied these changes and reported the issue to apple, hopefully this works, and hopefully apple also fixed this asap. It's really annoying. – cV2 Aug 7 at 14:06
-2

Its not a setting in notification. Its in app preference. Open mail->Preference or open mail and press short cut key (Command+,).

Uncheck below option. Hope it works.

enter image description here

  • Hi, Welcome to Apple.SE! At the end of my question, I have clarified that it pops up despite unticking the said setting. – ankiiiiiii Aug 7 at 6:49
  • Yup. Sorry didnt notice that. BUT, I haven't noticed any pop-up in my macbook after changing that option. – Md. Shouqatali C Aug 8 at 7:52
  • Maybe not in full screen, but behind other apps it might be happening. And as I updated the Q, it did happen yesterday in front of the app I was working on. – ankiiiiiii Aug 8 at 12:02
  • Hello, I did face the mail pop up in split screen again. Mails only from apple were coming so I found out below option to disable that as well. Let me know if it works for you. (Mail->Preferences->Rule) Deselect rule if any. – Md. Shouqatali C Aug 13 at 9:02
  • No rules either. – ankiiiiiii Aug 13 at 19:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .