2

This question already has an answer here:

Summary

I was recently provided with a 2018 MBP by my employer. The network throughput slows gradually until I'm forced to reboot.

Setup

The following machines are connected via wired ethernet to a gigabit switch:

  • 2018 MBP (the problematic machine, 10.14.4)
  • 2015 MBP (the control, thunderbolt ethernet adapter, 10.14.4)
  • 2010 iMac (the test target, built in ethernet, ubuntu)

The 2018 MBP has a usbc-thunderbolt adapter, with a thunderbolt display attached and the ethernet cable connected to the display.

When the throughput drops, I've tried the following:

  • Switch to WiFi - doesn't help, speed starts off around 300MBit/s but drops to the level the wired connection is currently at.
  • Use a different switch port / ethernet cable - doesn't help
  • Test speed on control MBP using 2018 MBP's ethernet cable & switch port (it's fine)
  • Connect thunderbolt monitor to control MBP and test throughput (also fine)
  • Disconnect usbc-thunderbolt adapter incase it's doing something odd (no difference)
  • Disconnect power from 2018 MBP (no difference)
  • Sleep/Wake 2018 MBP (no difference)

I setup a test to show the problem: rebooted the 2018 MBP then looped iPerf making connections to the iMac and plotted the results, sure enough after a couple of days I'm getting 10MBits/s across a gigabit switch:

throughput vs time graph

The problem isn't the iMac (test target) as I also made periodic tests from the control MBP to the iMac which consistently showed ~940Mbits/s.

I've been using the 2015 MBP and thunderbolt display with it's ethernet connection for years without issue, and have ruled that out as a cause. Also WiFi shows the same problem, which suggests its not related to a specific interface. I suspect a software problem with the networking stack on the 2018.

Potentially suspicious software:

  • Symantec Endpoint Protection (mandated by employer)
  • Pulse Secure (required for VPN connection to employer, but not connected during these tests)
  • Docker (required for development, does add bridges etc to local networking - this doesn't cause a problem on the 2015 MBP though.)

Questions

  1. Any idea what this might be about?
  2. Is there any way to reset the networking stack or some workaround that doesn't involve a reboot?

Unfortunately removing SEP is not an option :(

marked as duplicate by Community Jun 5 at 14:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You mention sleep/wake, presume you have the power plugged in whilst this test is ongoing so that there's no potential power throttling? – FiddleDeDee May 31 at 7:55
  • Yep, power was connected the entire time, apart from when I disconnected the power for a short time to check it wasn't a bad supply. – Hugh Saunders May 31 at 7:56
  • Reset PRAM? I know it's a new machine, but won't hurt to try. – FiddleDeDee May 31 at 8:04
  • Tried resetting the PRAM, long shot, but no difference. – Hugh Saunders Jun 3 at 13:38
  • Another person with the same issue: apple.stackexchange.com/questions/359723/… – Hugh Saunders Jun 5 at 10:45

Browse other questions tagged .