0

This question already has an answer here:

I tried to disable trackpad on my MacBook Pro 2015 my operating system is Mac OS X Mojave there is not have Accessability menu in System properties. So, how to disable it from Terminal?

marked as duplicate by nohillside terminal Jul 14 at 15:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

there is not have Accessability menu in System properties.

Look closer. Accessibility should be at the end of the fourth row of icons in System Preferences. If you don't have any third-party preference panes installed, this will be the bottom row.

The icon looks like this:

enter image description here

-1

I found this solution Disabling the trackpad from the command line, which is suggests the following command line:

sudo kextunload /System/Library/Extensions/AppleUSBMultitouch.kext/

which successfully disables the trackpad, but also the keyboard and a few minutes later the computer crashes and restarts.

Unfortunately the "Ignore trackpad when mouse or wireless trackpad is present" no longer works on Mojave. Because of well document bug where mouse starts jumping in uncontrollable fashion with the only solution being to disable the trackpad and use mouse, I've had that option checked for a while. But after an upgrade to Mojave, even when the option is checked the trackpad still reacts and the mouse is jumpy, which makes the computer mostly unusable (most apps don't have a very fluid shortcut keys support).

Bottom line: any suggestion to disable the trackpad, permanently and forever, on Mojave, not only when a mouse is detected would be amazing! :)

  • "The mouse is jumpy" -- Do you mean the pointer on the screen when using a mouse, or when using the trackpad? I've not seen any problems on Mojave using Trackpad on a MacBook Pro, and a desktop Magic Trackpad. Can you link to the documented bug? – benwiggy Jul 14 at 8:18
  • Please don't post follow-up questions as part of an answer. – nohillside Jul 14 at 16:15

Not the answer you're looking for? Browse other questions tagged .