4

I keep a lot of local HTML files on my machine, including my home page. Whenever I first open Safari, and often when going to any local file, I will receive an error. Hitting refresh (or, for the home page, the home button again) fixes the problem... until the next time you try to go anywhere.

Usually opening a link in a new tab prevents this from occurring; opening a link in the same tab almost always sees the error.

I realize "wait for Apple to get around to fixing it" is a valid answer; I also realize "use a different browser" is a valid answer. I'm hoping, instead, for a setting change I can make, or HTML tag I can add to my metric badger-load of files, to prevent this error without swapping browsers or waiting for an update (since it's already been happening for quite some time).

The error:

Safari Can't Open the Page

Safari can't open the page. The error is "The operation couldn't be completed.

(kCFErrorDomainCFNetwork error 1.)" (kCFErrorDomainCFNetwork:1)

Some potentially useful information:

macOS Mojave Version 10.14.4 (On a desktop, if that matters.)

Safari Version 12.1 (14607.1.40.1.4)

5
  • 1
    Some Googling on kCFErrorDomainCFNetwork error 1 indicates that it may be a file permissions error ... somewhere. That's all I got.
    – IconDaemon
    May 31, 2019 at 1:24
  • Interesting, I'm getting the same thing on Catalina PB 4 with Safari 13.0 Have you been able to figure anything out yet? Aug 10, 2019 at 23:30
  • You might have some luck with this solution: apple.stackexchange.com/questions/366448/… Aug 11, 2019 at 15:43
  • 1
    @MattSephton I'll check it when I get home today!
    – Ghotir
    Aug 12, 2019 at 19:08
  • I must have a different version of Safari - or different permissions - because that option didn't exist. I poked around for a bit with similar settings, but wasn't able to change the issue. I'll spend more time over the next few days (as time permits) investigating.
    – Ghotir
    Aug 13, 2019 at 16:42

2 Answers 2

2

I was having the same issue with my homepage which is stored locally on my mac. Putting the HTML files in the Applications folder seemed to solve the problem.

I know it's not the best solution but at least I don't get an error anymore when opening a new tab.

1
  • 1
    Just putting the home page here - and none of the other pages - seems to have fixed the problem. As you stated, it's sub-optimal... but better than hitting refresh every time I hit home.
    – Ghotir
    Sep 4, 2019 at 13:19
6

I was having the same issue. However, I also use Microsoft Edge and at some point, Edge asked me for permission and it worked again, though in Safari it didn't.

So I compared permissions and found out Edge got some permissions Safari never asked for. Giving Safari the permission "Full disk access" within System Preferences > Security and Privacy > Privacy tab> Full Disk Access , click the '+' to Add Software, then locate Safari to add to the list. This solved the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .