I currently have Boot ROM SW installed on my crippled Late 2012 iMac - which I upgraded HDD->SDD, tried to unsuccessfully install Mojave, then broke fusion setup, erased drives and am now stuck (see other questions on that...)

Specifically one thing I would like to try is to use the last standalone EFI update dmg from Apple support website Apple EFI and SMC Updates for my model (iMac13,2)

I can only access Single User Mode - I don't make it as far as Recovery with Utilities and Terminal options.

Is it possible to do this from Single User Mode? I can put files onto a Mojave or High Sierra external image which I could then access but I don't know enough about what commands and scripts to use to update firmware.


  • It is my understanding you can not go backwards with the firmware updates. Also, there is no way to reset to the factory original firmware. The only way to go backwards is to install a new logic board. – David Anderson May 28 '19 at 6:13
  • Wow. No offense but I really hope that isn't true! Anyone else have alternative views. Thanks for the quick response though David – Billzabub May 28 '19 at 7:04

The panic report you posted in your previous question indicates an unrecoverable error in the IOAcceleratorFamily kext while trying to communicate with the NVDAResman kext. This indicates a problem with the GPU, probably related to the weird firmware update you applied. I think you're out of luck at this point. Only Nvidia has software to downgrade a GPU ROM version, as far as I know.

  • Thanks for the analysis - that fits - BTW the firmware update was just from Mojave - nothing I did weird...ok... i've tried every else... going to change the logic board ... I got one from eBay... I might be a while... – Billzabub Jun 15 '19 at 23:27

Update from today - I went to Apple Authorized Repair center. They DID manage to run Apple Diagnostics Tests (unlike how others and myself have reported this is not working from Cmd-D) - it showed no errors from top level view. They then tried various boots and installs which all stalled as have mine at home.

They also tried to use a ROM update tool (non-public) to update from my ROM to latest compatible - I thought this was going to be - but when I got home I found that it hadn’t updated from :( What I really wanted was to go to back to last known good version before my upgrade - but they said the tool can only upgrade - not downgrade.

So no fixes to my startup issues related to Kernel Panics in Windows Server - so a strong suspect is the faulty GPU (even though High Sierra booted with GPU with an older ROM before I upgraded to Mojave)

I hate the idea of junking the whole iMac because of a SW/HW incompatibility introduced when I upgraded old ROM during failed install of Mojave

One of the weirdest things is that the shop also managed to get my internal drives up and running and recognizable by Target Disc Mode - they then erased and set them up as HFS+ drives (128GB and 1TB SSD).

However - when I got home I plugged into my 2018 Airbook with Thunderbolt 2 to Thunderbolt 3 /USB-C Apple adapter - and I still see nothing. I will try with neighbor’s old macbook Air with TB2 and see if that can see them… Why would a new macbook Air with Mojave 10.14.5 not be able to see these drives?

So I have a couple of options:

  1. Remove the 1TB SSD (and new 2x8GB Kingston HyperX RAM I just bought). Could also try to resell the refurbished PSU I just bought as well
  2. Buy a refurbished logic board for $500 and fit myself.
  3. Hang onto setup and keep hoping there is a SW/Firmware solution that someone finds in the future. Meanwhile I could buy a new iMac… I really miss having a ‘family’ computer for photo editing in the kitchen which isn’t a noisy slow ancient windows machine (which is what I replaced the iMac with for the moment)

Apple Diagnostics Working - yellow on memory is because 3rd party

  • I found a logic board for $220 on eBay. So I will see what happens when I fit that. – Billzabub Jun 3 '19 at 19:37
  • "The tool can only upgrade - not downgrade." This type of attitude from Apple annoys me to no end. Downgrading to a previously-working configuration is an extremely valuable troubleshooting step. – Wowfunhappy Jul 4 '19 at 21:03

I finally put my iMac together again with new/refurbished logic board. I'm an idiot so I managed to bend the CPU and lots of socket pins...(because it's kinda tricky getting heatsink on and connecting plate underneath without thermal paste attaching CPU to heatsink and shifting it out of proper alignment..

So this meant no boot - but then tried again unbending stuff - which has been a nightmare... anyway - imagine my surprise when it actually booted early this morning! (details of HW and SW below)

So... I'd now like to install High Sierra on the internal NVME 128GB SSD [no fusion] - leaving the 1TB internal SSD for Applications & Media

BUT do I need to watch out for either a Security Update or just Boot Rom update as part of installing High Sierra - or just later (or now) with Software Updates? [ I now have IM131.010A.B09 Boot Rom version ]



Model Name: iMac Model Identifier: iMac13,2 Processor Name: Intel Core i7 Processor Speed: 3.4 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 8 MB Memory: 32 GB Boot ROM Version: IM131.010A.B09 SMC Version (system): 2.11f16 Serial Number (system): xxx

  System Version: macOS 10.13.6 (17G65) [High Sierra] Version: Darwin 17.7.0   Boot Volume: Ext Mac OS HS [external Samsung T5 SSD]   Boot Mode: Normal   Secure Virtual Memory: Enabled   System Integrity Protection: Enabled

  • 1
    Shouldn’t this be an edit to your other answer? – bmike Jul 4 '19 at 22:10
  • Probably yes but still learning the etiquette here- sorry. I tried a comment to my answer but it said too many characters.. hence the new answer. – Billzabub Jul 5 '19 at 22:13
  • 1
    Well, a warm welcome! The best guidance I have is put everything in an answer, use the edit to tack on thoughts or remove thinking that’s clearer and discarded. Short questions, long answers, comments only about editing is best. – bmike Jul 5 '19 at 22:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .