4

Mac OS X 10.6.4, MacBook Pro, Apple Magic Trackpad.

The trackpad is unresponsive. Right-clicking on the Bluetooth icon in the menu bar shows me gray text that says "Bluetooth not available".

I don't see a system preference item in which to fight with this, but I don't see anything relevant.

6

According to this article, resetting the System Management Controller might to the trick.

Here's how to Reset the SMC on Apple's support site.

2

Under System Preferences there should be a bluetooth preference pane. Make sure it's set to 'on' and 'discoverable'.

1

In terminal, also remove the com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and com.apple.driver.AppleBluetoothMultitouch.mouse.plist files from ~/Library/Preferences.

cd ~/Library/Preferences
rm com.apple.driver.AppleBluetoothMultitouch.mouse.plist
rm com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

Then restart. That fixed it for me.

  • What does "also remove" mean here? What needs to be done addition to the removal of these files? – nohillside Mar 9 at 10:18
  • 1
    And why do you use sudo to remove files owned by the current user – nohillside Mar 9 at 10:19
0

Resetting the NVRAM as described here solved the issue for me:

https://support.apple.com/en-us/HT204063

-1

I fixed it by

  1. shutting down the machine
  2. removing battery
  3. keep power button pressed for 10 sec
  4. start machine again
  • 2
    At which point did you insert the battery again, 2b? And how long did you remove it? – nohillside Jun 5 '12 at 20:52
  • Better to follow the “how to reset SMC answer” since the steps vary per hardware. – bmike Mar 9 at 14:26
-1

I have fixed by the same method as above. shut down, remove battery, hold down power button for 10 seconds, replace battery and re-start

  • Better to follow the “how to reset SMC answer” since the steps vary per hardware. – bmike Mar 9 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .