1

I had an app called Ulysses classic. I'm not using it anymore, so I want to delete it. I select Delete documents & data under System Preferences → iCloud → Manage, but it didn't work and app remains in the sidebar showing 63 KB (same in my iPhone).

How can I remove it?

  • I have the same problem but with a different app. No matter which device I try to delete it with, it will not go away – Martin OConnor Jun 22 at 14:59
1

Welcome to AppleSE!

What you are seeing in that image is what is backed up in iCloud. You have to delete the app on iPhone by holding down its icon and then pressing the cross which appears when the icons start wiggling.

Then you'd be able to delete its data from iCloud by going to iPhone settings-> Account (First in the list with your name and photo)-> iCloud-> Manage Storage-> Ulysses classic-> Delete documents and data.

  • hi, thanks for answer I don't have that app installed in my iPhone or MacBook. I also tried remove iCloud data from iPhone settings but it didn't work. "Ulysses Classic" appears in purchased list (app store, macOS). I hid the application but I can't remove iCloud data. – user333539 May 26 at 14:57
  • How about reinstalling it and turning off iCloud for the app. Then it will prompt you to delete it again. Maybe it works! – ankii May 26 at 18:10
  • ok, I tried turning off iCloud backup from app but it didn't work neither. I used free trial but the app appears as "purchased" in app store. – user333539 Jun 6 at 2:24

You must log in to answer this question.