0

I am having a lot of problems with my Late 2012 27" iMac not booting (and not letting me install, run diagnostics tests etc)...

Ok... I'll try and keep this short as possible...

Late 2012 3.4Ghz 8MB iMac worked great for years - started to get some random restarts last year - was running High Sierra

Tried an update to Mojave - failed - and iMac no-longer would boot / kept power re-cycling

Took it in for repair at good authorized Apple repair center. They managed to get all data off the Fusion drive (128GB original SSD/NVME + 1TB HDD). They tried reinstalling OS (I think they put original Snow Leopard on there). But kept getting re-boots.

Told me it was likely a Logic Board fault which would cost $800 or I could leave with them for recycling...

I decided I wanted to try and save the machine - I had read that the PSU boards on late 2012 iMacs often caused this sort of problem - so I brought the iMac home - learned how to open it up (iFixit) - bought a refurbished different PSU board for $100 and fitted it.

Did a quick test - and it booted ! hurrah.

At this point I thought I would give the machine a bit of boost so bought a 1TB SSD (Samsung EVO 860) and swapped out the HDD for the SSD. I expected this to kill the fusion drive setup - and it did - but I was ready to install Mojave from external USB disk I had made

This didn't seem to work - but when I tried Recovery mode from Internet, It remade fusion drive, installed High Sierra - and booted! So was super happy, re-sealed screen to machine and had a working iMac again.

So then... I tried installing Mojave again (10.14.4)... seemed ok to begin with (1 min) then crash... then didn't boot and wouldn't even get to disk utilities or Terminal with my Mojave USB install disk

So I thought maybe the fusion disk setup was the culprit - and therefore if I could reset that - maybe unfuse the drives and install OS X to NVME and use the 1TB for applications and user data...

I bought a firewire cable (and a new Mac book Air....) and used Target Disc Mode - I could see drives - I ran first aid on them - no errors. I tried lots of different boot options - in the end I erased them both to try and get rid of fusion setup.

Everything I did hasn't helped getting past a stuck progress bar on the Apple Logo.

I can't do internet recovery, USB recovering, Paragon Hard Disk Manager USB Key, Apple diagnostics (via internet) - I get an error about Can't load EFI with cmd-D

So then I thought if its nothing to do with my internal drives (which should be blank) - maybe its my memory... so I tried removing one 4GB bank - same results. tried other... same results...

The only thing I can get into is Single User Mode - but not sure what to do there to help....

Before I start believing it is a logic board problem I really want to rule out some kind of SW/Firmware issue - or test HW somehow and check it works - but remember - I have NO OS installed at the moment

... update ...

things are getting worse - now I can't even see the drives in Target Disk Mode :( - the host is showing Firewire symbol - but no drives appearing on my Mac Book Air (which I just upgraded to 10.14.5 - hope that hasn't caused that). If I use Single User Mode (with the USB 10.14.4 key in) I see the drives are there (with ls /dev/disk*) - but I don't seem to be able to run fsck on them (only the USB 'root')

What do I need to do in Single User Mode to be able to a) check other drives, b) see them in Target Disk Mode please?

On another thread Apple Community there is lots of talk of the latest Mojave EFI Firmware 224.0.0 being buggy - e.g. stopping Cmd-D diagnostics from working:

Error: 0x8000000000000003, Cannot Load 'EFI/Drivers/TestSupport.efi' Status: 0x00000003

I get this too so I can't easily check what is working and what isn't

p.s. I changed my RAM tonight - NO change.

Thanks for any help B

Update Saturday:

Ok... I borrowed a neighbor's Mac Book Air which was running High Sierra 10.13.6. I installed an external bootable version of High Sierra on external USB/T5 SSD. It worked on his Mac. Remembered to change his Start Up drive to Internal before I finished with machine (that would have been awkward otherwise). Now when I do Option boot I get option of "Mac OS X 10.13.6" or "Recovery 10.13.6". They both get stuck on the apple loading progress.

The only thing I can think of which isn't a 'logic board failure' is boot rom mismatch now... (if it was HW then why was High Sierras running before I tried the Mojave update?)

How can I find out what Boot ROM EFI I have now (I suspect 224 still...) - and then downgrade? There is the last Apple EFI standalone ROM for this model - Late 2012 27" Intel 3.4 on this page - https://support.apple.com/en-us/HT201518 is there any way to update Boot firmware from Single User Mode?

... Update

Single User Mode works and obviously this is better position now that it is a full Mac OS X disk (10.13.6) environment

All the other internal drives are enumerated

I don't know enough about diagnosing things from this point.

With system_profiler I see:

BOOT Rom Version: 283.0.0.0.0 SMC version: 2.11f14 Sys SW: 10.13.6 (17G65) Booted external Sec. Virt Mem: enabled SIP : enabled

When I look in var/log/System.log there isn't much some info on Kernel panics too

Where do I go next to figure out why booting, or anything other than Single User Mode isn't working please?

  • Also tried with external 10.14.5 USB - see other post. Seems to be issue when UI process starts and window server not happy. There is mention of ambient light sensor fn so I'm paranoid I didn't connect up cable properly before I glued everything back together.... Ugh – Billzabub May 27 at 7:40

You must log in to answer this question.

Browse other questions tagged .