0

I have a Mac with Mojave installed on an APFS partition. I run sysadminctl to change the Secure Token status for some users.

Based on the information I found on the web it wasn't clear to me how I should run it (sudo vs no sudo, interactive mode or not).

It turns out that depending on which variant I used:

$ sysadminctl interactive -secureTokenOn user -password - 

vs

$ sudo sysadminctl -secureTokenOn user -password - 

--the system window asking for administrator's password had a different text inside it.

(I also tried the remaining two combinations but only the above two seemed to work.)

The first command (interactive, no sudo) asks for the password to "unlock Users & Groups preferences". (I use a localized version of macOS so screenshots wouldn't be useful, but it's the same window as in this video: https://youtu.be/-BaOKzwEiy0?t=48)

Now, the second command produces a similar window but the text inside it says that the password is required to "unlock the disk" (note it's my translation, the actual English text might be different).

My question is: is it just a bug in sysadminctl or is there a difference between the two commands?

You must log in to answer this question.

Browse other questions tagged .