7

Starting this morning, every time I try to add an item to my iTunes library, a blank window appears. I can close it, and in the main iTunes window there's an exclamation mark in the top right corner. If I click on it, a dropdown appears with the information: Adding item to library cancelled.

For clarity: I am not trying to add new files, I'm just browsing the iTunes catalog and trying to add items from there.

I have an active Apple Music Account so I see no reason why I should not be allowed to add an item from the iTunes Store.

Any suggestions on what the problem might be and how to solve it? Thanks.

MacOS Mojave 10.14.4 / iTunes 12.9.4.94

11

It's a known bug since the release of macOS 10.14.5.

The blank window that shows up when you try to add an item to your library is actually supposed to contain new terms of service that you have to agree to, but it's bugged on macOS and just displays an empty page instead.

The only solution right now seems to be to go to Apple Music on any of your iOS devices (iPhone, iPad) and add a random item to your library there, then restart your iTunes on Mac and it should be fixed.

This bug has been around since 10.14.5 Beta and Apple still hasn't fixed it, which blows my mind, because it basically makes Apple Music unusable for anyone without an iOS device.

  • 3
    Solved it for me, thanks! – Richard Kranendonk May 21 at 9:35
  • I spent an hour on the phone with Apple to no avail. This cleared it right up. – Jadasc May 23 at 16:41
0

You can items to iTunes then they will appear in your iTunes library.

  1. In the iTunes app on your Mac, choose File > Add to Library.

  2. Locate a file or folder, then click Open.

  3. If you add a folder, all the files it contains are added to your library.

0

Tried not working for me. But inspired by this solution, I did it this way,

  1. Open Itunes with my Iphone
  2. In Apple music, select a song not on my playlist, create or add to any playlist.
  3. Apple music asked me to approved new rules,answered yes.
  4. back to normal, can add music to library in any devices.
0

This solution didn't work for me at first.

My iPhone is in German, and the German terms of service would not load. After trying a few times, the English terms loaded, which I accepted. Not sure why that happened, but you may have to temporarily change languages if this issue persists for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .