1

I was trying to install windows 10 on my MacBook Pro 2012, I was following apple tutorial (https://support.apple.com/pt-pt/guide/bootcamp-assistant/bcmp09f5f773/mac)(or in English). I chose 100GB to windows partition. Everything was going great until I came across "no bootable device insert boot disk and press any key" message. I went back in MacOS to remove the Bootcamp partition to repeat the process again, but I couldn't find it. Here are some prints from disk utility: enter image description here enter image description here

what can I do to undo and resize the original MacOS partition to try to do the bootcamp again?

Thank you in advance and have a great weekend!

diskutil list: enter image description here

  • Enter the command diskutil list in a Terminal application window and post the output to your question. – David Anderson May 18 at 20:15
  • Thank you David! updated – xicobito May 18 at 21:00
0

This is a very common question. To reclaim the lost space, enter the command given below.

sudo diskutil apfs resizeContainer disk0s2 0

Some of the Windows 10 ISO files released by Microsoft can not be transferred by the Boot Camp Assistant to a flash drive as described by the document you referenced in your question. This is either because the flash drive is too small or needs to be ExFAT formatted.

If you are still failing to install Windows though the use of the Boot Camp Assistant, then consider using the following steps to install Windows.

  1. Use the Boot Camp Assistant to download the Windows support software. In this case, you are prompted where to store the files to be downloaded.
  2. Use the Disk Utility application or the diskutil command to create space for Windows.
  3. ExFat format and 16 GB or larger flash drive and copy the files from the Windows ISO and Windows support software download.
  4. Boot from the flash drive and install Windows. Basically, you are installing Windows the same way as anyone who owns a PC.

An example of one user who recently successfully installed Windows 10 using this method can be found at the question Mojave bootcamp assistant limits partition size.

  • Thank you so much David! I think it worked! Sorry if my questions are a bit basic, I'm just a beginner. I formatted my flash drive as MS-DOS (FAT) as they suggest (support.apple.com/en-gb/guide/bootcamp-assistant/…). It's a PNY 32GB. Maybe I should try with a different flash drive. – xicobito May 18 at 23:50
-1

UPDATE: I tried a different flash drive, TOSHIBA 16GB USB2.0, and it worked!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .