Strange problem: when I import photos from my iPhone 4S (5.0.1) into iPhoto 11 (latest), MOST of the images show as all black. Strangely, almost all landscape photos are imported/displayed ok, however every portrait shot shows as black.

If I reveal in finder, the modified files that iPhoto creates are 162kb black jpgs, however the original files are the correct photos.

I've rebuilt my iPhoto '11 library, to no avail. After reimporting, portrait images are still black. For some reason, iPhoto is changing/corrupting the 'modified' versions of the photos upon import.

Thinking this is a bug either in iPhoto or relating to the iPhone 4S (this never happened with the 4...)

FWIW It's being discussed in the Apple Support forums here.

I also tried importing the photos via Image Capture then into iPhoto, and same result. So it's an issue with how iPhoto processes (modifies) the photos into it's library.

I believe this issue only seems to affect iOS5 users...

  • I'm not so sure this is an iOS or iPhone issue. It seems to be an iPhoto 11 issue. My wife just imported photos from our Canon 500D camera into iPhoto 11 on her new Macbook air, and this exact problem turned up. All landscape photos are ok, all portrait photos are pitch black. Originals are fine, but modified versions are blacked out. Commented Jan 29, 2012 at 21:17
  • If you "crop" them on iPhoto they will turn out normal!
    – user25762
    Commented Jul 25, 2012 at 20:41

3 Answers 3


As forbca said in his/her answer in the support thread you linked to, the issue seems to be resolved if you reboot.

I had the same issue. After a reboot, I'm able to import the photos correctly into iPhoto. Just grab the originals and re-import them in iPhoto. You'll be asked about duplicates – import the portrait photos anyway.

It seems to be a bug in an iPhoto update that only turns up if you haven't rebooted since the update. The corrupted imports were done on a laptop that had over 30 days of uptime.

  • This worked for me. Such a simple solution - I was used to rebooting back in the Windows days, but forgot it can be necessary even in OSX. Commented Jan 30, 2012 at 23:53

You're not alone, there are several discussions along these lines in the Apple Support Forums.

The solution:

  1. Backup your iPhoto Library if necessary. (Insert mandatory lecture about routine backups if you don't already do so.)

  2. Rebuild your iPhoto Library by depressing command + option while starting iPhoto.

  3. Check the option for repairing Library permissions.

  • I rebooted per @Martin's answer above and also repaired Library permissions per this comment. Not sure which did it, but new imported photos look right. Old ones sadly do not. Suppose I could re-import from the originals if nothing else.
    – Henrik N
    Commented Feb 25, 2012 at 22:56

There appear to be different home grown solutions to this problem.. Here's another:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .