Due to reasons I do not understand, my mac (macOS High Sierra, 10.13.6) does "copy on select". I have no idea when it started, and I assume it comes from one of the tools I am using. Is there any way of finding out why it is doing this? I switched of Keyboard Maestro and BetterTouch already, but still the same.

Any suggestions?

  • What is this feature? a screenshot would be helpful I think? – ankii Oct 2 '19 at 13:48
  • 1
    @ankii - this shows copy on select in terminal. It works like this by default in Mojave with other apps as well (Safari for example) if selecting and copying text within open Windows. For example you can select text in Safari and drop it into terminal. Would be interesting if OP means it is putting it in clipboard though (like cmd+C) which this doesn't. – lx07 Oct 2 '19 at 14:22

I had the same issue and by trial-and-error found out, that it only happened while the Unclutter App is running.

The issue was solved for me after I quit Unclutter. Though this solved the issue for me, your behavior might be caused by some other app...

General recommendation

My suggestion is, that you first quit all clipboard-managers (if you have any). If that does not solve the issue, quit one app after the other, even Dropbox, etc.

Also test, if the issue happens inside a specific editor only. For example, if it only happens inside Visual Studio Code, then you might have installed a plugin in Visual Studio Code that enables the behavior.

When the problem is not limited to a single editor, open your "System Settings > Security > Privacy" panel and check, which apps have access to "Accessibility". Try to revoke all Accessibility permissions...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .