1

I'm using iCloud keychain with multiple devices but when trying to turn it on on my new iPad (running iOS 12.3) the setting is not saved, so if I choose Keychain and turn on iCloud Keychain, and then get back to the iCloud settings, they Keychain option remains off.

I've been trying to restart the iPad, logout and login to iCloud but it didn't help.

1

You'll need to approve the iCloud activation from another device. It may pay to check your Apple ID has a valid phone number associated, so you can receive an SMS verification.

From Apple Support https://support.apple.com/kb/HT204085:

If you can't access any of your other devices that are using iCloud Keychain, you can still set up iCloud Keychain on another device if you have these items:

  1. Your iCloud Security Code

  2. The device that is using the SMS-capable phone number you provided when you first set up iCloud Keychain. A verification code is sent via SMS to this phone number. If you can't access this number, contact Apple Support, who can verify your identity, so that you can complete setup on your new device.

After you complete the setup, your iCloud Keychain will be pushed from the cloud to the new device.

If you use two-factor authentication with your Apple ID, enter your password and the six-digit verification code that's automatically displayed on your trusted devices and authorize the new device. Then turn on iCloud Keychain.

  • 1
    I already approved the new device when signing it up with iCloud. When I try to enable type iCloud Keychain I am not being prompted to enter a security code. – user49204 May 17 at 6:04
0

Following Apple support advice solved the problem:

  1. Reset network settings
  2. Logout and login
  3. Reset all settings
  • For me this problem was created after logging out of iCloud and back in. The only thing I had to do to correct it was to log out of and back into iCloud again. Resetting of settings was not necessary in my case. – TransferOrbit Sep 25 at 19:33
  • Logging out from iCloud and then in again solved it for me. – Simon Oct 10 at 15:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .