I have a new mac-mini with HDMI + 2 thunderbolt-hdmi adapters. Waking up the mini results in screen blanking repeatedly as it adds and removes displays. Repeatedly. Like 20 times. For 2+ minutes.

I blame displaypolicyd but cannot find any documentation related to it. The output in /var/log/displaypolicy/displaypolicyd.IGPU.log updates during the blanking, having entries like:

u>234091110954 LinkUpdate: 2.0 event: Insert [0]
u>234091111015 NOTICE: Addr: 2.0 event: Insert [0] source: 0
u>234091271092 NOTICE: Do online device addr 2.0 processCount 1
u>234091279665 NOTICE: Sync LinkTrain Port: 2: SST, 2 lanes @ HBR2
u>234091363536 NOTICE: FB AGDC state FB[0] - ON
u>234091363604 NOTICE: inject FB[0] change
u>234091400720 NOTICE: Do online device addr 2.0 - completed
u>234091685347 NOTICE: kIOFBNotifyOnlineChange 0x6 fb[ 0 ] -> online, Wed May 15 12:37:36 2019
u>234091685426 NOTICE: Update display map to fb[ 0 ] - online
u>234094043845 LinkUpdate: 2.0 event: Remove [1]
u>234094055235 NOTICE: Addr: 2.0 event: Remove [1] source: 0
u>234094055258 NOTICE: Do offline device addr 2.0 flags 0x0
u>234094055276 NOTICE: FB AGDC state FB[0] - OFF
u>234094055316 NOTICE: inject FB[0] change
u>234094237162 NOTICE: kIOFBNotifyOnlineChange 0x7 fb[ 0 ] -> offline, Wed May 15 12:37:38 2019
u>234094237198 NOTICE: Update display map to fb[ 0 ] - offline
u>234094237208 NOTICE: Release fb[ 0 ] resources
u>234094237244 NOTICE: Do LT off on port 2
u>234094237264 NOTICE: Port[2] - DP link down
u>234095319140 LinkUpdate: 2.0 event: Insert [0]
u>234095321284 NOTICE: Addr: 2.0 event: Insert [0] source: 0
u>234095492773 NOTICE: Do online device addr 2.0 processCount 1
u>234095501124 NOTICE: Sync LinkTrain Port: 2: SST, 2 lanes @ HBR2
u>234095583915 NOTICE: FB AGDC state FB[0] - ON
u>234095583964 NOTICE: inject FB[0] change
u>234095618927 NOTICE: Do online device addr 2.0 - completed
u>234095916433 NOTICE: kIOFBNotifyOnlineChange 0x6 fb[ 0 ] -> online, Wed May 15 12:37:40 2019
u>234095916542 NOTICE: Update display map to fb[ 0 ] - online

Why cant it just wake up and keep the last display configuration it had? I'm tempted to play with the config, but fear rendering the mini display-less.


The Thunderbolt-HDMI adapters are Apple D200s seen here: https://www.apple.com/shop/product/MJ1K2AM/A/usb-c-digital-av-multiport-adapter

The displays are Dell U3415W and two Dell U2413s. No DisplayLink adapters are involved (though I have several of those laying about).

  • Please specify exactly what brand & model of Thunderbolt > HDMI adapters you are using. Not all off-brand adaptors are created alike, and many are simply shoddily constructed or never work at all. From professional and personal standpoint, Belkin® brand adaptors have proven to be the best at work and home. Disclaimer: I'm a satisfied user of Belkin® products. No financial or other ties to the company.
    – IconDaemon
    May 15 '19 at 21:16
  • BTW, the Apple adapters are most likely fine, though expensive. However, you still need an HDMI to HDMI cable. One of the reasons why I love those KingOne’s is there’s no middle man. It’s USB-C on one end and HDMI on the other. It’s unfortunate that you had to saw down the opening, though. Upvote for actually checking the console log instead of just saying “it don’t work right!” Jun 14 '19 at 7:00

I suggest getting high-quality USB-C to HDMI cables. You should never see link retraining messages unless your cables are flaky. I've had great luck with these: https://smile.amazon.com/gp/product/B073YPBWKB/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

I run 4 4K monitors off my 2017 15" MacBook Pro, 2 from each side, one goes through an OWC Thunderbolt 3 Dock and it NEVER re-trains. No drivers or tweaking necessary.

  • Bought that exact cable - plugged mac-mini thunderbolt3/usb-c to hdmi on the Dell U2413. No response at all. Display only shows Power Save Mode in 5 minutes. No updates to any log files in /var/log when I plug the cable in anywhere.
    – ericslaw
    Jun 1 '19 at 1:53
  • HDMI connector does not fit Dell HDMI ports -- tried on three monitors... ended up testing with a chromecast 3" extension and it works. Now to see if it does retraining.
    – ericslaw
    Jun 1 '19 at 2:14
  • Was no room near HDMI port - large head of the cable didn't fit (was not the connector itself). Small snips made more room (on the monitor, not the cable). Will buy another cable and do more testing -- thanks
    – ericslaw
    Jun 1 '19 at 2:33
  • 1
    Without the ability to test with non-Dell monitors, I cannot tell if the issue is with the Apple D600 multiport adaptors and/or the Dell monitors, but moving to the cable solution suggested here resolved the issue completely.
    – ericslaw
    Jun 3 '19 at 2:58

Had similar issues for awhile, resolved via...

  1. Changing combination of adapters / cables / ports as underlying ASICs (Application-specific Integrated Circuits) seemed to have different preferences / properties / thresholds.

  2. Disabling 'Energy Saving' / 'Eco' / Etc. mode on connected displays.

  3. Connecting displays to non-'eco controlled' (master / slave) outlets on surge protector / UPS (if using one).

My assumptions are (and flag if you wish to, anyone ; ) a combination of utilized ASICs in active / passive adapters & cables ± the state of software / hardware development and compatibility across vendors.

Some references which outline the spec as well as some of the same / similar issues below but, essentially, getting Apple, VESA / DisplayPort, DisplayLink, third-party vendors, etc. all on the same page and playing perfectly nice with each other can be… 'tough'.

(Apparently I can't actually share all the links to the references so… workaround = shared Evernote here.)

P.S. Since my case did involve (1) actual USB DisplayLink device [USB w/ DVI-I Dual Link-to-HDMI adapter then HDMI cable to display] in addition to (1) Mini DisplayPort-to-HDMI cable + (1) pure HDMI male/male cable, that’s a lot ICs and muxing in the mix there, only one of which was declared DisplayLink, so who knows what’s inside the others? Perhaps installing the newest DisplayLink drivers resolved multiple issues, therefore might suggest as a potential #4 scenario. (Driver download link is the last one listed above. : )


  • I appreciate the detail, including the disabling energysaving mode, but I wish to at least disable the displays overnight to reduce energy use.
    – ericslaw
    May 17 '19 at 21:06
  • The above still fully supports display sleep per desired settings (i.e. System Preferences > Energy Saver > 'Turn display off after: 1 min - 3 hrs' or whatever you prefer / set), just that you're essentially making macOS the master controller by removing all the other variables versus allowing the display manufacturers to confuse and complicate the process. (Kinda how it should be imho. ; ) How can I sum it up? Um... 'Too many cooks in the kitchen' comes to mind, if you catch my meaning. Getting rid of all the other cooks allows the 'Master Chef' to cook & control things properly. May 17 '19 at 23:14
  • Speaking of variables, ideally disable everything for full functionality then walk back (re-enable) one-by-one until problem element is isolated. Best case = perfectly customized settings per your preferences, worst case = you gain the knowledge of knowing precisely which element in the chain is the... pain. ; ) May 17 '19 at 23:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .