0

Recently my mouse cursor is disappearing a lot and I can't make it visible again until I slide where the mouse should be up to the menu bar and click the menu bar.

How do I fix this?

Some people think this is same question as: Fix invisible cursor?

Maybe it is? But that's for an older OS, and the OP of that question has accepted an answer that doesn't fix the problem for me.

I want to prevent the problem from happening at all ("fix").

I have already detailed how I can get my cursor back when it disappears, but it's really annoying and I want that to not happen.

The other question some people flagged as duplicate doesn't help out at all.

  • If you shake your mouse, does the cursor become bigger allowing you to see it ? I lose my cursor all the time and that action helps me a lot ! – Edd Growl May 14 at 15:24
  • @EddGrowl I am not losing it, it literally becomes invisible. – theonlygusti May 14 at 16:22
  • yes that is what I meant, sorry for the confusion. Sometime when I use the full screen mode on an app my cursor vanish and doesn't come back until I shake my mouse. I was wondering if it was the same issue here. – Edd Growl May 14 at 16:26
  • @EddGrowl doesn't seem to work for me. Only clicking on the menu bar or revealing Mission Control shows the mouse again. – theonlygusti May 14 at 16:35
  • Possible duplicate of Fix invisible cursor? – Mark May 14 at 17:00
1

Looks like a someone had this issue as well and accept the answer here : Fix invisible cursor? :

If your mouse cursor has mysteriously disappeared in OS X, try the following tricks in descending order to bring it back:

  1. Hit Command+Tab to switch back to the Finder or to another app, then switch back to the active app

  2. Summon the Force Quit menu by hitting Command+Option+Escape, there is often no need to actually force quit anything as just summoning the menu is often enough to make the cursor return

  3. Quit and relaunch the app, or quit all apps if the cursor is gone everywhere

  4. Adjust the size of the cursor, found in System Preferences > Accessibility > Display to make it reappear

Reboot

Also, he commented that :

Slightly increasing the cursor size in system preferences seems to have fixed the issue entirely.

  • "Slightly increasing the cursor size in system preferences seems to have fixed the issue entirely." didn't work. The rest of this answer is not a solution. – theonlygusti May 14 at 16:51
  • Don't copy an answer from another question. If the answer is the same then you shpould flag the question as a duplicate so any new readers will see a pointer to the actual answers – Mark May 14 at 16:57
  • Some other people claim they fixed the issue with an NVRAM reset ( described here : support.apple.com/en-ie/HT204063 ) – Edd Growl May 14 at 17:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .