1

All of a sudden, I don't have the feedback sound when I turn the volume up or down on my touch bar. I have tried resetting NVRAM, resetting the SMC, tried the secure boot mode to see if the problem occurs here as well (the touch bar volume buttons are actually disable when I turn on the secure boot mode), and I also tried using another user account - the problem persists. I've also connected my MBP to my bluetooth speaker, and here I also do not hear the feedback sounds.

As you can see from my screenshot, the play feedback when volume is changed box is checked, as is the play user interface sounds. The interface user sounds seem to work, as I can hear sounds for incoming emails, or messages, even phone calls ring on my phone.

I went into system preferences, keyboard and customized the touch bar. I removed the volume control, restarted the computer, added it again to the touch bar and the feedback sound worked momentarily. But now it does not work again.

I also noticed that when I press the shift key on my keyboard and press the volume up or down buttons on the touch bar that the feedback sound is there again. Weirdly enough, when I do it on my MBP, the sound is quite normal but when I connect the laptop to my bluetooth speaker, so sound crackles and does not give feedback upon pressing the key each time ...

PLEASE HELP! All this started today when I wanted to watch a youtube video and notice that I didn't have any sound at all - not on youtube, not on netflix, not in itunes. I managed to fix this, though I am not sure how, either be restarting numerous times or, most probably, through resetting the NVRAM. Now, all my sounds work - no problems with playing back music, or videos. But why does the volume up / down feedback not work? I have also noticed that the sound of the feedback when I press the shift key and the touch bar button is different from the sound it used to make. I'm using macOS 10.14.4 enter image description here

  • Alright guys, guess what? As I was desperately typing all this, the 10.14.5 update came up and I just installed it. The feedback on the volume button works now! However, the sound is different than it was before ... but the main thing is that it works. Anyone have any idea though what could have caused this in the first place? – IrBer002 May 13 at 22:22
1

Please select a sound device in the output tab.

Also, try toggling the mute icon.

  • Thank you for your suggestion; both options did not work. I kept toggling the mute icon, the sound output device also made no change ... I'm still not sure what happened, but the update to macOS 10.14.5 fixed it - I'd be interested to know if anyone else has had the same problem. – IrBer002 May 15 at 6:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .