0

I've noticed that when I try to open a file in any newly added applications, the application opens, but not the file. I've noticed this problem with multiple Wine versions, and also web-based games.

I haven't had this problem before.

I've tried re-installing macOS Sierra, deleting ~/Library/Prefrences/com.apple.LaunchServices/ and ~/Library/Prefrences/com.apple.LaunchServices.plist and then relaunching Finder, but still have this problem.

Mid-2012 MacBook Pro, macOS Sierra, 10.12.6

  • What if you open application and then go to the open menu item? There should be an 'open' option under the File menu on most apps. – jmh May 13 at 23:39
  • @jmh I am currently re-installing macOS Sierra, but I've tried this with Wine. When I have Wine('s terminal GUI) open and I click 'Open With Wine', it just opens another Wine('s terminal GUI) window. – Sam May 13 at 23:43
  • For some apps, the 'open' options works with, but not all apps have that option, and for some reason this problem only affects apps installed within the last (about) two weeks, with one exception (Wine Stable 4) – Sam May 14 at 0:15
  • @jmh this problem persists after I've re-installed macOS Sierra – Sam May 14 at 0:16

You must log in to answer this question.

Browse other questions tagged .