When using iTunes for AAC conversion, sometime only a part of the song is converted (also, when playing the song, iTunes does not plays it entirely and skip to the next one before the end).

But when I use another app (like MediaHuman Audio Converter for conversion or IINA for playing), the song is converted/played entirely.

The issue clearly comes from iTunes but I cannot find it. I looked up into the information of the songs having the issue in iTunes but the pre-ended box is not checked.

So far I tried to :

  • consolidate my library (from Apple support)

  • rebuild a new Library with the .xml file (following that procedure)

  • reboot into safe mode

but the problem still remains.

It appear that when testing with a new user account (with same file), iTunes manage to do it...

I never signed into my Apple ID, and my library is stored on my boot volume (~40,000 songs 200 Go).

Anyone with a similar issue and/or knows how to solves it?


It looks like the issue only occur when opening a full album into iTunes, and that the duration of each song will be equal to the shortest one (for example : if the shortest song is 2:36, every other will skip at 2:36). Sometimes it goes well for the first song of the album (even if it´s not the shortest one) but after playing a shorter one, the skip loop begin...

By adding the song of the album one by one into iTunes, everything works fine...

I just updated to macOS Big Sur (11.6.1) and Music have the same issue.

  • What is the version of iTunes and macOS/Windows running on your computer?
    – Nimesh Neema
    Commented May 17, 2019 at 6:56
  • I´m on the latest version of iTunes (12.8.2) and mojave (10.14.4). But I had this issue with previous version of iTunes/OS so I think it is irrelevant.
    – Edd Growl
    Commented May 17, 2019 at 11:27
  • What are you converting from - a CD track? a downloaded music file in what format?
    – nekomatic
    Commented May 17, 2019 at 12:08
  • Mostly downloaded file in .mp3
    – Edd Growl
    Commented May 17, 2019 at 12:16

2 Answers 2


As a troubleshooting step I would start with booting into Safe Mode to see if the behaviour is replicated there, and also to see if the behaviour continues again afterwards when you've logged back in normally.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. can iTunes play and convert full songs or not?)
  6. Now exit Safe Mode by restarting your Mac as normal
  7. Log in normally and test again

Once you've booted into Safe Mode, let me know how you went and we'll go from there.

Test with a new user account

Okay, let's now test to see if this behaviour persists in a newly created user account.

  1. Go to Apple > System Preferences...
  2. Select the Users & Groups preference pane
  3. Click on the plus sign at bottom left (you may need to unlock the padlock first)
  4. Now add the details for the new account and click on the Create User button
  5. Once created, click on Login Options
  6. Ensure that automatic login is off
  7. Also ensure that the Show fast user switching menu is enabled
  8. Exit preferences

Now log into the newly created account (there should be an option at top right of the menu bar), download an .mp3 file and test iTunes again.

Let me know how you go.

  • Just did, same issue in Safe Mode and after rebooting normally.
    – Edd Growl
    Commented Jun 8, 2019 at 13:05
  • Have just added another troubleshooting step for you to try.
    – Monomeeth
    Commented Jun 8, 2019 at 22:36
  • Ok, so I made a new user account and iTunes managed to convert my test album correctly. I tried again in my account but it skiped most of the song again. Do you think the error is due to my large library (~28000 songs 125 Go) ?
    – Edd Growl
    Commented Jun 8, 2019 at 22:53
  • @EddGrowl Well, iTunes, since around mid-to-late 2015, has been able to handle 100,000 songs (previously it was limited to 25,000). I wonder if it's related more to what iTunes is doing when it's signed into your Apple ID? Is it performing a lot of background tasks (e.g. syncing, downloading podcasts, etc) while you're trying to do the conversions etc? I also wonder if there's some file corruption causing problems?
    – Monomeeth
    Commented Jun 9, 2019 at 8:14
  • In terms of further troubleshooting, can you advise whether your iTunes music library is stored on your Mac's boot volume, or is it on an external disk? In the new user account, was iTunes signed into your Apple ID or not? Also, did you use the same test album in both accounts?
    – Monomeeth
    Commented Jun 9, 2019 at 8:14

I had the same problem and could solve it by converting the songs using a new iTunes library (no need for me to try safe mode or create a new user account).

  1. Close iTunes
  2. Hold Opt and then re-open iTunes
  3. Select New library and choose where to store it
  4. Add your song and convert them, check if they are converted well and entirely
  5. Export them somewhere on your computer (ie. Desktop)
  6. Close iTunes
  7. Hold Opt and then re-open iTunes
  8. Select your regular library
  9. Add converted songs to your regular library
  10. Delete the new library you have created only for conversion purposes


  • Nice catch ! But then, using MediaHuman seems easier...
    – Edd Growl
    Commented Nov 30, 2022 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .