I have different information related to installation new SSD.

If we will try search through Amazon help it shows that the disk Samsung SSD 860 EVO 500GB will work fine with MacBook Pro 13 inch Mid 2012:

Also I saw this video where all works good as well for similar system.

But my disk recognized as uninitialized in my Mac OS Mojave 10.14.4 (18E227):

I tried diskutil as well to format my disk and here is an error after some time waiting for creating portion map:

diskutil eraseDisk JHFS+ SAMSUNGSSD disk1
Started erase on disk1
Unmounting disk
Creating the partition map
Error: -69825: Wiping volume data to prevent future accidental probing failed

Also first time there was another error: error: couldn't open device

Before this Samsung SSD 860 EVO I have KINGSTON SSD SATA3 240gb disk and all worked good for me. But few days ago Mac OS accidentally crashed and after restart I just saw flashed question-mark folder. I bought new Samsung SSD 860 EVO. Now I am trying to format my Samsung SSD 860 EVO but because of some reason I can't do it not at terminal nor using disk utility.

I read some information about replacing SATA cable, but not sure I need to do it as my previous KINGSTON SATA 3 SSD worked good with the same cable. Maybe port or cable is corrupted I don't know, but not sure if my cable model is different to one that user suggest to buy to make it work:


My System:

enter image description here

enter image description here

enter image description here

enter image description here

  • I'd replace the cable. On certain macbooks of that era it was normal to replace the cable when you replaced the dirve. I was unable to locate the specific model. – historystamp May 11 '19 at 19:48
  • got it, I tried to format to another format and looks like it created portion for me. But when I copy file there, it shows an error. I will try cable replacement Thanks – Matrosov Alexander May 12 '19 at 7:47
  • 860 EVO worked for me on a 2011 MBP. Yes, this is different but I do not think it is makes that much difference. SSDs use SATA protocol, which is more or less the same support across devices. I never heard about any compatibilty issues with these SSDs. I guess the problem is not related to the drive itself. – Unnamed_1 Nov 28 '19 at 7:56

You must log in to answer this question.

Browse other questions tagged .