3

This is probably not the first case, but I have tried various methods to recover the lost 50 GB of space from different threads, but neither one of them work. (After removing Boot Camp partition, took a little effort to finally remove all the partitions, but the space used went missing.)

Tried Internet Recovery to go into Disk Utility app didn't work.

Tried using Terminal (not very good at it), so basically copied & pasted some of the commands others have shared, and changed the necessary disk numbers, didn't work for me.

So I figured, might be good that I just post & hopefully someone could give me some advise.

This is what I got:

screenshot

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best with your question. – Monomeeth May 10 at 11:37
  • Can you elaborate why Disk Utility did not work. It is not the most straightforward app, but for this kind of problems it is usually well equipped. – n1000 May 10 at 12:34
1

This is a very common question. Generally, the commands below should work.

sudo diskutil erasevolume free none disk0s4
sudo diskutil resizevolume disk0s2 R
0

This site is littered with very detailed, yet very arcane methods of achieving this, written by people far smarter than me.

I still think the simplest & safest way is to buy Paragon Hard Disk Manager & do it from a GUI.

  • I wish I could get everyone to pay me $40 to type two commands. – David Anderson May 10 at 10:57
  • @DavidAnderson - It's knowing that in this case 2 commands might do it, compared to the dozens of 'oops, I did this & made it worse' that you & klanomoath have had to dig through over the years. – Tetsujin May 10 at 11:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .