1

I tried multiple file systems and multiple devices, none of them will mount. I also tried looking for fsck (not running), resetting the NVRAM (and restarting the Mac of course) and it still doesn't work. It shows up correctly in the Disk Utility, however it stays unmounted (even if I click mount). Is there anything else I can do? What might be wrong? FYI I did check the following thread (although my problem is a bit different) and tried these solutions, didn't work.

enter image description here

UPDATE As requested by the comment, I ran the following:

diskutil list disk2
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            ClickShare             *23.5 MB    disk2
8
  • In Terminal, what is the output of the following command? diskutil list disk2 Copy the output from Terminal and paste it into your answer. Commented May 9, 2019 at 13:35
  • @user3439894 Updated the question as requested.
    – lte__
    Commented May 9, 2019 at 14:14
  • I've never seen a 23.5 MB USB Flash drive and there is information missing in the output that I'd expect to see. How was this USB Flash Drive formatted? Commented May 9, 2019 at 14:19
  • It's a ClickShare device (FAT16), 23.5 MB is valid. But I have the same symptoms with my external HDD.
    – lte__
    Commented May 9, 2019 at 14:21
  • And also another pendrive that's not a specialised device.
    – lte__
    Commented May 9, 2019 at 14:21

0

You must log in to answer this question.

Browse other questions tagged .