1

I have several rules in macOS Mail app version 12.4 set to detect certain senders and/or subjects, with the action to delete the matching emails.

Here's an example rule: Example rule

However, I see they're instead archived (moved to "All Mail", still marked as unread).

Here're my Mailbox Behavior prefs: r

Here're my Gmail IMAP settings: gmail imap settings

I've no filters in my Gmail webapp. Anyone else experience this?

1

Check settings in Gmail itself. In "Forwarding and POP/IMAP", what's the setting under "When I mark a message in IMAP as deleted:"? And if that is set to "Auto-Expunge off" - what is the setting for "When a message is marked as deleted and expunged from the last visible IMAP folder:"?

I have the first option set to the default (Auto-Expunge on), which prevents you from modifying the second option. But deleting an email in my mail client immediately sends it to the Trash folder, not the Archives folder.

  • I've added a screenshot of my Gmail IMAP settings above. They're set to the defaults: auto-expunge on; when deleted/expunged from IMAP, archive; no size limits. – jtheletter May 9 at 23:08
  • If I confirm an email is in both my Mail app inbox and Gmail webapp inbox, and I manually delete the email in Mail app, the I refresh Gmail in my web browser, I see the message is moved to Gmail's trash. – jtheletter May 9 at 23:09
  • If I turn auto-expunge off, I can change the second part from archive to trash. If I change auto-expunge back on, the second part changes back from trash to archive. I'll try auto-expunge off and second part trash, and I'll wait for another rule to trigger and see if this resolves it. – jtheletter May 9 at 23:16
  • I've also got my mail client set to auto-expunge mailboxes on exit. Don't recall if that's a setting in Mail.app or not, I primarily use Thunderbird. – dr.nixon May 10 at 16:54
  • After changing Gmail "auto-expunge" to "off" and "when deleted/expunged from IMAP" to "trash", the behavior isn't changed. Emails that Mail app's rules should delete are found unread in All Mail. – jtheletter May 10 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .