1

I hope i am posting in the right place because i am really desperate. Since yesterday at noon, when i woke up my mac by lifting the screen, it stopped showing me my usual username, asking for my password and started prompting me to specify my username as well. My profile picture is gone as well. It wont accept my username and my password as valid login data.

Here are all screenshots, for some reason i cant upload them properly:

https://imgur.com/gallery/hxUhm9I

Here is what i have tried so far:

  • I can boot into recovery mode, but my Macintosh HD does not even show up in Disk Utility.

  • I have reset the PRAM

  • when starting in single user mode, my mac calls (to me at least) suspiciously many processes with crypto in their name (my HD was never encrypted!)

  • when runnig fsck in single user mode my mac even calls two processes called “handle_crypto_mount“

  • When runnig fsck in single user mode it returns with “error: snap_metadata_val object (oid 0x1d7ca0): invalid extentref_tree_oid (0x0)

  • I have tried googling this error; the most commom suggestion seems to delete all tmutil snapshots. My mac finds one normal snapshot an one dataless snapshot, but deleting these fails wether the local drive is mounted (?) (mount -uw /) or not.

It seems to me that my mac is thinking for some reason that its harddrive is encrypted with filevault or something of the like which it has never been and acutally isnt at the moment either.

I am really lost people, i usually consider myself not that bad at computers but i just dont know what to do anymore.

Please help me

Also: if i posted this in the wrong place, please kindly point me to the appropriate place

  • I presume this is the link that you have looked at? discussions.apple.com/thread/8092082?page=1 - it talks about there being a dateless snapshot and searching from the root. There was also talk of a large chunk of disk space that had been reserved for TimeMachine. – FiddleDeDee May 8 at 9:41
  • Yes thats exactly what i looked at – vionccc May 9 at 10:08
1

Have you turned on FileVault 2 encryption? If you have, you can enable your third account by doing the following:

Open System Preferences
Click on Privacy & Security.
Click on the FileVault tab.

There should be an Enable users... button showing in the FileVault preference pane. Click it and you should be given the opportunity to enable the third account by providing the account's password.

On restart, the third account should now appear at the login screen.

  • Priti do you mean create a new third account? – Stefan May 8 at 5:50
  • I will try to look into that even though i have never activated filevault. My HD is definitely not encrypted, except if it for some reason encrypted itself without my input or knowledge – vionccc May 9 at 10:10
0

In case anyone finds this desperately searching for an answer, i may not be of much help:

I solved my problem by physically removing my Harddrive from my MacBook, deleting everything on it by connecting it via a USB adapter to another Mac, reformatting it and re installing a new version of MacOS from a live USB Stick i created with another Computer.

I guess my Harddrive was just to full for Mac OS to function reliably and it messed up itself badly with the time machine backup.

I also replaced my Sata - HD cable because it was causing problems as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .