When using Safari, it will attempt to autofill passwords and credit card numbers for me. However sometimes (more than once per login) it will ask me for me computer login password.

Previously it would autofill the password without asking for my macOS login password. This changed when I enable two-factor authentication on my Apple ID. (I cannot disable two-factor because I am registered with Apple Developers.)

How can I make autofill actually autofill my password like it used to, without asking for my password?

Please do not recommend TouchID as a workaround for this issue.

enter image description here

2 Answers 2


I just ran into this problem as well, I found that it was only happening on my MacBook with the Touch ID fingerprint scanner.

If this is true for you as well then you can turn the password prompt off by going to System Preferences > Touch ID and unchecking the box next to Password Autofill.

  • 6
    You're a hero! thanks a lot! This was driving me nuts on my new M1 Air
    – AlphaX
    Feb 4, 2021 at 21:42
  • Fingerprint never works for my wife and this was driving her bonkers. Thanks!
    – sfjac
    Apr 4 at 17:41

Well, you could wear an Apple Watch, but I'm guessing you won't like that answer. ;-)

BTW, I've been seeing the same behavior and consider it strange, possibly a bug introduced in macOS 10.14.4

Safari should only be asking for your password once, if you haven't used the autofill feature or authenticated against your Apple ID in 15 minutes.

If it's asking for your macOS login password, that's because your key chain has been locked. Try changing your login password then rebooting. Hopefully your keychain will remain unlocked after you log in again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .