2

I deleted existing Spotlight Indexing on my MacBook Pro running macOS Mojave by executing:

sudo rm -rfv /.Spotlight-V100

Now I don’t see anything - no apps, downloads, trash, nada. How do I undo this? I tried adding folders to Privacy tab in System Preferences > Spotlight, and then removing them, but it didn’t help.

  • 1
    Try rebooting... – lhf May 7 at 10:54
  • How long did you wait for the effects? Have you tried closing SysPrefs between steps, rebooting. What's the output of ls -la / now (do you see .Spotlight-V100 in the list)? – LangLangC May 7 at 10:54
  • Plus: Where did you get the screenshot from? (Which guide did you follow)? – LangLangC May 7 at 11:01
1

It looks like you disabled Spotlight indexing via Terminal commands, then tried to restore the default behaviour via graphical user tools (System Preferences).

That may fail as some guides for the Terminal are really 'thorough'.

In the screenshot above you have the commands:

Prevent indexing:

sudo touch /Volumes/YourVolumeHere/.metadata_never_index

Disable indexing and searching:

sudo mdutil -i off -d  /Volumes/YourVolumeHere/

Delete existing index:

sudo rm -rfv /.Spotlight-V100

To reverse these steps

sudo rm -i /.metadata_never_index
sudo mdutil -i on /Volumes/YourVolumeHere/

To remove the file that tells Spotlight to 'never index here' and turn on again the indexing and search on the drive.

The Spotlight folder should be recreated as needed. It may take a while and a reboot won't hurt.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .