To give some background, I have some HomeKit devices set up in my home and they work great. I've successfully been able to add the rest of my family to the home with the exception of one person.

With this person, I am able to send the invite in the usual way, and they receive it. However, the problem comes when they try to accept it; after clicking Accept, my device shows that they are now added to the home. The problem is, though, that this member of my family never gets past the accept stage - they cannot access the HomeKit setup like we can. Instead, they get stuck on this screen with the spinning wheel for a seemingly infinite amount of time:

After trying the obvious things like removing them, re-inviting them and logging out/into their iCloud account, I became frustrated and did some googling. It seems that this is (or used to be) a common issue as you can see here. The strange thing is that all the instances I could find of this problem occurred mid-2018 when I understand there were problems with that version of iOS regarding HomeKit. As a result, I made sure to check that all of this family member's devices were on the most current version of iOS (12.2) - which they were, and thus I am now stuck and unaware what else to do.

Does anyone have any idea what is causing this issue and what can be done to resolve it?

  • What are you using as your Hub? Have you tried investigating that as the potential culprit? As for the one person having problems, what device are they using? Also, do they have another device they can test with (in order to narrow this down to a specific device, rather than a specific account)?
    – Monomeeth
    May 15, 2019 at 7:58

2 Answers 2


I recently had the same issue and was able to resolve it with the steps I described in this answer https://apple.stackexchange.com/a/371383/10494

  • 1
    Thank you for your answer. Luckily, the issue was resolved once the problem family member updated their devices to iOS 13.
    – Rocco
    Oct 3, 2019 at 23:22

I have been having that problem for a while now, but I followed the first solution in this Reddit post and it worked.


  1. revoke all the invitations you were sending to that person
  2. sign off iCloud on their phone
  3. then sign in on that phone using your own iCloud account
  4. whilst signed in as you, open Home app and see your accessories and scenario show up
  5. when you sign out of your iCloud account and re-sign in as your family member's, they should be able to accept the invitation with no problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .