1

I have a document written predominantly in a Left-to-Right language, but I also have a few quotes in a Right-to-Left language.

I would like to add ellipses in the end of such (Right-to-Left) quotes, but I am unable to do so.

If the quote has multiple lines, the ellipses end up at the bottom right (as if I was writing Left-to-Right), not the bottom left, as you can see in the following gibberish sample.

أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص هذا مثال على النصهنا ، نهاية النص ...

This makes me think that these characters (or anything that replaces three dots for an ellipsis symbol) are in fact Left-to-Right oriented.

How do I write a Right-to-Left ellipses so that I get something like the following?

‫ أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص أبجد هوز هو مجرد دمية النص هذا مثال على النصهنا ، نهاية النص ...

Since markdown on this site doesn't allow proper right-to-left justification, an illustration using Latin characters:

‫ tfel mottob eht ta sespille na htiw sdne dna tfeL-ot-thgiR morf ereh seog txet cibarA …* ‫

*(read it Right-to-Left)

I am using Pages 8.0.

1

For creating an RTL document:

  • open Pages
  • Create New Document
    • in the Chooser, select in the lower left corner "Language" Arabic (Egypt or the region you prefer)
  • be sure to have the appropriate InputSource (Keyboard) selected
  • Start typing.

For writing Right-To-Left within an existing document/changing the document to RTL:

File > Advanced > Language & Region –– Select something Arabic

Based on Use bidirectional Arabic and Hebrew in Pages, Numbers, and Keynote

In a document that mixes LTR and RTL scripts:

Change writing direction: On your Mac or iCloud.com: Click Format button enter image description here, then click Right to left button enter image description here.


Caveat: In macOS Pages v7.1 on Sierra and on Pages 8.0 on Mojave this mixing (often?) just doesn't work at all – initially – in a default install with English as the main system language: as the button apparently intended to be used is missing altogether.
On the current iCloud.com version it appears on the right to "Alignment" (as it should in macOS Pages):

iCloud Pages version of the pasted text from question, proper script direction

That means there is a long running bug in Pages or a common trigger/setup problem that OP and I share. Under these circumstances only typing by hand produces the desired correct RTL orientation for RTL languages.

To get this button to display I had to

  • open System Preferences > Language and Region
  • if not already present: add a Right-to-Left language like Arabic or Hebrew to your list of "Preferred Languages" (via plus button below the list)
  • drag Arabic to the top position as primary language
  • restart Pages and quit Pages
  • drag English back to the primary spot

Pages then seems to retain the ability to display the right-to-Left switch button – and use it. An alternative that's also enabled then is in the menubar: Format > Text > Reverse Text Direction.
(kudos to Tom Gewecke whose comment hit the spot on this one)

  • I tried this. It does not seem to have any effect. Does this work on your machine? – Nanashi No Gombe May 5 at 17:06
  • The double arrows icon seems to be missing. – Nanashi No Gombe May 5 at 17:11
  • @NanashiNoGombe If you can't see the button, use Format > Text > Reverse Text Direction – Tom Gewecke May 5 at 17:35
  • @LangLangC What font are you using for the text? – Nanashi No Gombe May 5 at 17:36
  • 1
    @TomGewecke Indeed it is absent. – Nanashi No Gombe May 5 at 17:37
1

I have no problem typing ellipsis using Pages 8. I have Smart Quotes enabled in Edit > Substitutions and just switch the text direction using the arrows or the Format > Text menu item depending on which language I am typing.

enter image description here

  • The typingon clean new lines after switching input methods/keyboards is not the problem. The problem is pasting something that Pages doesn't immediately recognise as Arabic (RTL) into a LTR doc. The Writing Direction is present and works in TextEdit! – LangLangC May 5 at 17:57
  • I checked on three Macs now 10-12/7.1; 10.14/8.0 (2x), the double arrow and the Format/Text functionality are completely invisible in all three setups, two of the setups I controlled and may have misconfigured somehow, but the third is supposedly 'clean' (that's what she said ;) I always thought that Pages was just not ready for this, but it seems we circle around a bug? – LangLangC May 5 at 19:32
  • 1
    @LangLangC I'm really puzzled that the text direction items would be missing for you. Pages got full RTL capability via these buttons with version 5 in 2013. I've followed it closely over the years, and never saw that problem. Is your OS running in English? Try adding a Hebrew keyboard. See if having both Arabic and Hebrew on the preferred languages list makes a difference. Put Arabic at the top of your preferred languages list, restart Pages only, see if the button is there, then quit Pages and move English back to the top of the list. – Tom Gewecke May 5 at 20:26
  • Well. Hebrew is always in the list, but only putting it or Arabic at the top of preferred langs and restarting Pages made the arrows appear. And stay, curiously . The last bit with dragging RTL to top and then launching Pages twice did it. Thx. – LangLangC May 5 at 20:33
  • @LangLangC Glad to hear that worked! Should not be necessary of course. – Tom Gewecke May 5 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .