1

I have an Apple MacBook Pro with Mac OS Mojave 10.14.4 running. Since 10.14.2 or 10.14.3 (I can't remember) the internet connection times out every 2 minutes or so. It takes then from 20 sec to 1 min to load a web page. This happens for Chrome, Firefox and Safari-Browser, which I tested. This happens whether I use WiFi-connection or Ethernet-cable. A typical ping for my WiFi-connection looks as follows:

MacBook-Pro:~$ ping 8.8.8.8

64 bytes from 8.8.8.8: icmp_seq=56 ttl=120 time=15.381 ms
64 bytes from 8.8.8.8: icmp_seq=57 ttl=120 time=18.708 ms
64 bytes from 8.8.8.8: icmp_seq=58 ttl=120 time=13.254 ms
64 bytes from 8.8.8.8: icmp_seq=59 ttl=120 time=937.689 ms
64 bytes from 8.8.8.8: icmp_seq=60 ttl=120 time=1901.038 ms
64 bytes from 8.8.8.8: icmp_seq=61 ttl=120 time=2934.408 ms
64 bytes from 8.8.8.8: icmp_seq=62 ttl=120 time=3958.543 ms
64 bytes from 8.8.8.8: icmp_seq=63 ttl=120 time=4908.217 ms
64 bytes from 8.8.8.8: icmp_seq=64 ttl=120 time=5905.401 ms
64 bytes from 8.8.8.8: icmp_seq=65 ttl=120 time=6842.036 ms
Request timeout for icmp_seq 72
64 bytes from 8.8.8.8: icmp_seq=66 ttl=120 time=7862.743 ms
Request timeout for icmp_seq 74
64 bytes from 8.8.8.8: icmp_seq=67 ttl=120 time=8889.559 ms
Request timeout for icmp_seq 76
64 bytes from 8.8.8.8: icmp_seq=68 ttl=120 time=9843.350 ms
Request timeout for icmp_seq 78
64 bytes from 8.8.8.8: icmp_seq=69 ttl=120 time=10892.615 ms
Request timeout for icmp_seq 80
64 bytes from 8.8.8.8: icmp_seq=70 ttl=120 time=11936.543 ms
Request timeout for icmp_seq 82
64 bytes from 8.8.8.8: icmp_seq=71 ttl=120 time=12980.791 ms
Request timeout for icmp_seq 84
64 bytes from 8.8.8.8: icmp_seq=72 ttl=120 time=13820.231 ms
Request timeout for icmp_seq 86
64 bytes from 8.8.8.8: icmp_seq=73 ttl=120 time=14764.972 ms
Request timeout for icmp_seq 88
64 bytes from 8.8.8.8: icmp_seq=74 ttl=120 time=15707.589 ms
Request timeout for icmp_seq 90
64 bytes from 8.8.8.8: icmp_seq=76 ttl=120 time=15748.127 ms
Request timeout for icmp_seq 92
64 bytes from 8.8.8.8: icmp_seq=78 ttl=120 time=15691.715 ms
64 bytes from 8.8.8.8: icmp_seq=79 ttl=120 time=14686.667 ms
64 bytes from 8.8.8.8: icmp_seq=80 ttl=120 time=13683.104 ms
64 bytes from 8.8.8.8: icmp_seq=81 ttl=120 time=12678.182 ms
64 bytes from 8.8.8.8: icmp_seq=82 ttl=120 time=11673.334 ms
64 bytes from 8.8.8.8: icmp_seq=83 ttl=120 time=10668.399 ms
64 bytes from 8.8.8.8: icmp_seq=84 ttl=120 time=9664.758 ms
64 bytes from 8.8.8.8: icmp_seq=85 ttl=120 time=8661.137 ms
64 bytes from 8.8.8.8: icmp_seq=94 ttl=120 time=28.665 ms
64 bytes from 8.8.8.8: icmp_seq=95 ttl=120 time=15.928 ms
64 bytes from 8.8.8.8: icmp_seq=96 ttl=120 time=15.640 ms

This repeats periodically. The same behaviour, when I switch off WiFi and put an Ethernet cable onto the computer. As I have another computer in my home network having no network problems this seems to be a problem of this machine, but I have no idea what might cause it.

Any help is greatly welcome! Wolfgang

  • How about pinging internal nodes like the router? Do you still have the latency? Do you disable WiFi when using Ethernet? – Allan May 6 at 1:49
  • I tested with WiFi disabled and enabled when using Ethernet - same behaviour. When I ping another computer in my home network I get no request timeouts, but quite strong variations in response time (factor 20). – woju May 7 at 21:16
1

This question has been asked previously in this site (1, 2), and in many other forums, but not answered particularly well. I have, on a couple of occasions, experienced bouts of chronic network timeouts, but they have "cured themselves" after a restart. Your problem sounds persistent, and my curiosity was piqued. So here's what I found:

From OSX Daily is an approach that requires you delete a set of files in /Library/Preferences/SystemConfiguration/. Apparently these are files the system generates, but it sounds like you'll need to re-enter the settings, and that could be an effort if you've made a lot of WiFi connections. The procedure is basically as follows:

  • Turn off Wi-Fi in System Preferences or menu bar.
  • Remove aall Thunderbolt or USB devoces connected
  • Create a backup folder & copy the files you will delete below into it

Here's the list of files to be copied to a backup folder, and then deleted from: /Library/Preferences/SystemConfiguration/:

- com.apple.airport.preferences.plist  
- com.apple.airport.preferences.plist-new
  
- com.apple.network.identification.plist
  
- NetworkInterfaces.plist  
- 
preferences.plist  

There is also this article from OSX Tips that, essentially, prescribes the same approach. It's recent vintage (March, 2019), and that could be taken as some sort of affirmation that it still works?

So, if you're in the mood to be a guinea pig, try this, and let us know if it worked!

  • I have in /Library/Preferences/SystemConfiguration the following files: NetworkInterfaces.plist com.apple.smb.server.plist com.apple.Boot.plist com.apple.wifi.message-tracer.plist com.apple.accounts.exists.plist preferences.plist com.apple.airport.preferences.plist I deleted the first and the two last and rebooted. When I chose my home WLAN (the data were still present) I got the same timeout problem as before. – woju May 7 at 22:16
  • I'm sorry that didn't resolve the issue. Perhaps this one will yield better results? – Seamus May 9 at 19:15
  • I followed every advice on the page, including a reinstall of Mojave - no effect. However, I noticed, if I boot into safe mode, the request timeouts seem to be gone. What does this tell me? – woju May 12 at 14:29
  • @woju: Not sure... according to this, wifi may not even be available. Let me think on this & I'll follow up later. I've got to run now. – Seamus May 12 at 15:16
  • I was using Ethernet cable in safe mode. – woju May 12 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .