3

I'm testing SD Flash Cards and my linux machine decided to be rude and stop operating the SD Card Reader (time for a USB device). So I switched over to the reliable old iMac to happily find that F3 can be installed via Homebrew. After the brief installation however, Bash cannot find f3probe, an essential testing tool that is supposed to come together with f3 for SD Card Fraud testing. F3Read and Write do appear, while no commands or manual entries exist for f3probe or f3fix.

sudo: f3probe: command not found

Thanks for your time,

Tmanok

1

brew install f3 installs the two commands f3read and f3write into /usr/local/bin (but no f3probe).

From the README:

    make extra

.. note::
   - The extra applications are only compiled and tested on Linux
     platform.
   - Please do not e-mail me saying that you want the extra
     applications to run on your platform; I already know that.
   - If you want the extra applications to run on your platform, help
     to port them, or find someone that can port them for you. If you
     do port any of them, please send me a patch to help others.
   - The extra applications are f3probe, f3brew, and f3fix.
-1

You are looking for the Fight Flash Fraud / f3 application. This is a third-party application that you will need to install.

Use Homebrew and run

brew install f3

Or alternatively download the f3 package directly here. Add the directory location you unzip the binaries to your PATH and you should now be able to run f3probe

  • Hi Hanxue, perhaps I wasn't clear "I switched over to the reliable old iMac to happily find that F3 can be installed via Homebrew" I ran the exact command you suggested and has resulted in the exact problem I'm asking about. I will however download and install via the other link you provided in the meantime. – Tmanok May 5 at 4:49
  • After downloading and following the installation guide "unzip", "make" and "make install". After which, I realized that f3probe would not be installed without additional commands. I ran "make extra", "make install-extra" failed due to: "libdevs.c:19:10: fatal error: 'linux/fs.h' file not found" – Tmanok May 5 at 5:00
  • Additionally, the GUI app fails to run on Mac OS Mojave. This is becoming concerning as I'm not new to GitHub or new to Homebrew. – Tmanok May 5 at 5:02
  • 1
    @Tmanok If you need help in getting the Git GUI application running, please ask a new question here on AD. If you need help in porting f3probe creating an issue on Github (or asking a focused question for a specific issue on StackOverflow) should get you started. – nohillside May 5 at 8:13
  • 1
    @nohillside Ok will do. Sorry the problem started to spread significantly as I tried Homebrew, MacPorts, GitHub Compiling and then finally the application. I will find some time this week to ask relevant questions in more appropriate places. I appreciate everyone's help. – Tmanok May 5 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .