3

This question already has an answer here:

I installed Firefox on my Mac. The problem is that upon launching it, the title bar of the window appears stuck below the macOS Menu bar and hence is inaccessible.

enter image description here

I tried to zoom in and out, but it only zoom's the content. I'm unable to resize the window. Any ideas how can I fix this?

marked as duplicate by user3439894, Allan macos May 4 at 1:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Your problem description is unclear. Consider rewording it to better explain what are you observing vs. the expected behavior. – Nimesh Neema May 3 at 19:11
1

The easiest way I've found to bring a window back from under the Menu bar is to resize the window by pressing and holding the shift key and grabbing the left or right side edge of the window and dragging the mouse inwards towards the center of the window.

This resizes all four sides of the window at the same time, thus making it smaller and bringing the top of the window out from under the Menu bar.

You can then afterwards move and or resize the window as wanted on the screen.

  • Learned something new today :) – Nimesh Neema May 3 at 21:21
  • Note that this solution is only applicable to windows that are sizable in this manner. Some windows may not work with this method and an alternative solution will be needed. – user3439894 May 3 at 22:02
0

I hate it when that happens.

Try doing the four-finger swipe up (Mission Control), then drag Firefox lower on the screen.

If that doesn't work, try killing Firefox by right-clicking on its icon in the Dock and clicking Quit.

  • "Try doing the four-finger swipe up (App Expose), then drag Firefox lower on the screen." This won't work. The second approach too may most likely not work. – Nimesh Neema May 3 at 20:32
  • I do it all the time. Literally just did it with pdfPen. – Wilfred Smith May 3 at 20:35
-1

A very simple solution is to temporarily hide the Menu bar. Go to System Preferences app → General and check Automatically hide and show the menu bar.

This will hide the Menu bar, which can be easily revealed by hovering the cursor towards top of the screen.

Now once the menu bar is hidden, carefully move the cursor just upto the Firefox title bar, without touching the edge of the screen. Drag the Firefox window to suitable location.

Once done, you can disable Menu bar autohide.

Not the answer you're looking for? Browse other questions tagged .