0

I have multiple Eclipse IDE installed on Mojave (Eclipse is not in Apple Store).

They serve different purposes, and are of different version like Photon, Oxygen and so on. This is needed for the environment I am working in.

If I paste them into the application folder to have them shown on Launchpad only one shows up. Even if they are all named differently.

What's even more odd it's that if I remove all the versions from the folder it keeps showing the icon of the most recent Eclipse.

To solve this I rebuilt the Launchpad and got my fresh clean Launchpad panels, I firstly pasted Eclipse Photon in the application folder and it worked. Then I pasted Eclipse 12 (renamed for the occurency) but it overwrited the other just like as before.

Similar questions have been already solved that doesn't resolve mine, here are the references:

  • I think this is launchpad looking a the CFBundleIdentifier in the info.plist for the app and not showing duplicates (see here) – greg-449 May 6 at 6:59
  • @greg-449 I did as you suggested but I got an error inside Eclipse while Committing and Pushing. Reverting the changes you suggested removed the error. Maybe changing CFBundleIdentifier could mess with the Git configuration...I really don't know. – Docrates May 6 at 9:48

You must log in to answer this question.

Browse other questions tagged .