1

I have an iMac running macOS High Sierra. Recently I setup my system so that my Desktop does not show the connected drives and doesn't show anything on my Desktop.

My desktop is completely clean. I also had many files and folders on my desktop. All those are hidden as well. I can't remember how I did that and now I'd like to change settings or turn it off but can't. Does anyone know how you would do what I have done and can tell me?

I have all the boxes checked in the Finder preferences panel so thats not the issue.

I remember a pull down menu with several options for displaying the desktop. I just don't recall how I got to the pull down menu.

1

The description of the problem in question is possibly a bit ambiguous. But the most common causes for these symptoms are:

  • The individual Finder preferences are one option, described in wch1spink's answer. But with these options deselected regular files should still appear on the Desktop.

  • Another option would be using the defaults-system (as often this variable is set to a certain state by many 3rd party GUI tools of the type "CustimzeHiddenFeatures" as well, as described by user3439894' answer). With the following variable set to false only the Desktop background picture is shown, regardless whether any files exist at the path ~/Desktop/:

    To check whether this was done, enter in Terminal:

     defaults read com.apple.finder CreateDesktop
    

    If that shows as result: "The domain/default pair of (com.apple.finder, CreateDesktop) does not exist", the following will not do much.
    If the result is shown as: "false", then proceed, as we've found the problem:

    To hide desktop icons, copy and paste each of these into Terminal

     defaults write com.apple.finder CreateDesktop false 
     killall Finder
    

    To show desktop icons again, (i.e. the default state, even the variable is unset)

     defaults write com.apple.finder CreateDesktop true  
     killall Finder
    

    alternatively, completely unset the variable and let the defaults take over again:

     defaults delete com.apple.finder CreateDesktop
     killall Finder
    

    So in this case one of the last two commands would be the one needed to reverse the situation of unwanted barrenness of the Finder's desktop.

  • i editted my answer to try to explain things better. – jmh May 3 at 14:00
  • 1
    @imh, What's the output in Terminal of the following command: defaults read com.apple.finder CreateDesktop If it's The domain/default pair of (com.apple.finder, CreateDesktop) does not exist, then this answer is not applicable to your situation. – user3439894 May 3 at 14:04
  • @jmh This "pulldown menu" isn't found in Finder (but likely a "CustimizeThings" app). And that most probably wrote such a variable behind the scenes. Have you tried that last variable (It just sets the default state)? – LangLangC May 3 at 14:04
  • 1
    Yes it wasn't in Finder but I can't recall where it was. – jmh May 3 at 14:07
  • 1
    @LangLangC Thanks for your help. if i don't get the exact answer i'm seeking by tomorrow i will accept you answer since it works fine. – jmh May 4 at 1:56
1

In Finder, go to menu item Finder > Preferences and you will see your options there.

enter image description here

  • I have all boxes checked so that is not the problem. Thank you for your answer though. I remember a pull down box where I had several options to select from. I chose one that changed the desktop to its present stae. – jmh May 3 at 3:41
1

One possibility is if you used a tool like OnyX. As shown in the image further below, with the Hide the desktop icons check box ticked, and with all the Finder > Preferences > General > Show the items on the desktop: still ticked, there will be no icons on the Desktop.

Additionally, the output of defaults read com.apple.finder CreateDesktop in Terminal will be: 0

The default setting for CreateDesktop in the com.apple.finder.plist file the preference key is non-existent, so if it is set and the icons are hidden, then to return to the default setting, run the following compound command in Terminal:

defaults delete com.apple.finder CreateDesktop; killall Finder

There is also an app called TinkerTool that has some Finder settings that may do the same thing.

enter image description here

  • Right. I guess OP conflates the 4 options provided in Finder with a 3rd-party-customize tool. (But it's still possible that one of them organises its options in a pulldown? None I know does it via menu…) – LangLangC May 3 at 14:31
0

Finder Preferences-> General. Turn off showing everything. Set your dock to auto-hide. Set the menu bar to auto-hide (both from System Preferences).

  • 2
    You said "Turn off showing everything"... I have to say that is poorly worded and doesn't really describe how to resolve the issue. Additionally, why are you telling him to hide the Dock and Manu bar. He wants to see everything again! Suggest you reread the OP! – user3439894 May 3 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .