0

I had a MacBook Pro 2017 stolen. Luckily I have 2 backups:

  • Time capsule (day old)
  • Carbon Copy Cloner USB hard drive (30 days old)

MacBook Pro 2017 was running Sierra (or High Sierra?) now I forgot MacBook Pro 2018 came with Mojave

This is what I've tried so far:

  1. When the brand new MacBook prompted me to restore from Time Capsule, I accepted. It connected and ran the whole night restoring files. When I came to it in the morning it said it was finished but there wasn't a single file that was successfully restored. No users, no apps, nothing, just as if I got it fresh from the factory. Just like if I never ran the restore in the first place. But I saw it run, I was waiting for it the whole night.
  2. I switched to CCC next. First I had to fight with allowing booting from external devices (because of the T2 chip). I got that sorted out by going to command-R and allowing it.
  3. Next, even though it now let me boot external drives, I would get the "no-go" icon (circle with a line through it). I figured out that it was probably due to another incompatibility.** So I booted the USB drive on my mac mini and successfully upgraded it to Mojave there.
  4. After this I was able to boot into Mojave on both Mac Mini and the new MacBook Pro. (All my files were there too)... so close....
  5. I thought the final step would be as easy as blowing away /dev/disk1 (reformat) and then cloning from USB to /dev/disk1 using CCC. I even gave CC extra permissions it asked for (for contacts and calendars or something like that). It said it completed successfully but during boot (from internal SSD now with USB disconnected), it would go about 75% at the apple logo before showing "no-go" icon.... ARGHH!!!! ... WHY? It only works through USB
  6. Next I tried using disk utility to clone USB to internal HD but it completed with error "RPC version wrong"

I'm out of ideas. Why is this so hard? Is it the damn T2 chip fighting me a each step? Am I just doing all this wrong? What's going on?

** I simiplified this step a lot because the following details are not important (I hope). In reality it was much more strange than the summary I wrote. The very first time after I successfully allowed booting from external drive, I was able to boot from the USB drive, but it popped up with a window saying that my OS was incompatible and that I should click next to upgrade to Mojave. I didn't do it right in that moment because I didn't want to corrupt my one and only CCC backup on that USB drive. So instead I shut the whole thing down and took a backup of my USB by doing dd on Linux. From that moment on I was working with the clone. To my shock, the next time I tried booting both of my USB drives went straight into the "no-go" icon .. I wasn't prompted to do the upgrade to Mojave as I have been prompted before. Somehow that Mojave upgrade offer was a one shot deal. That's what gave me the idea to boot up on my Mac Mini, upgrade to Mojave inside there and then carry on. That worked (for a while) if you keep reading on.

  • I used CarbonCopyCloner to copy my old 2012 Mini to my new T2 2018 Mini. Even though both were Mojave, I had to reinstall the OS after cloning, using Recovery (Command R). Then I could boot from the internal disk. I had another problem with SecureBoot, but you're past that. – benwiggy May 3 at 20:54
1

Use “Migration Assistant” instead of attempting a direct restore. This mitigates hardware change issues, T2 issues, minor OS difference issues, some software licensing issues, and a few other potential issues.

  • That was step 1) which failed. But I guess I will just try that again. – user3280964 May 3 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .