1

I downloaded the zip file of iterm, unzipped it and copied the iterm.app folder to /Applications from terminal. When I open the iterm file in applications, I still get the prompt to move it to Applications folder. Tried moving it to Users applications folder too. How do I avoid this error?

  • Odd, I just downloaded iTerm2 from iterm2.com, unzipped it and put it in /Applications. All I got was the warning about opening files downloaded from the internet. Nothing about what you say, so it is unlikely to be coming from the app itself. What if you log in as another (new) user and do the same thing, are you still prompted? – Steve Chambers Apr 30 '19 at 20:36
  • I could have been specific. I get that prompt only when I copy/move the folder from terminal. – pdna Apr 30 '19 at 20:42
1

Although this is hard to check, it seems like Gatekeeper was being overly-protective, but has since been adjusted.

When using macOS Sierra (10.12) or later, if an app is in /Applications/ but prompts to be moved to /Applications/ when run, then chances are very high that the app has recognized that it has been subjected to Gatekeeper’s “app translocation”. If you’re interested in the details you can find them online, but the practical effect is that if you went into Terminal (or iTerm) and ran

ps auxwww | fgrep -i YourAppHere

You would see a path that is not /Applications/YourAppHere.app but more like /private/var/folders/[something-random-looking]/AppTranslocation/YourAppHere.app.

The preferred way of moving apps around (according to Apple) is with the Finder. If you drag an app from the ~/Downloads/ folder to /Applications then it will not be 'translocated'.

If you insist on not doing things Apple’s preferred way, your only option is to remove the quarantine flag from the app. This will remove all of Gatekeeper’s protections, so use at your own risk. You can remove the quarantine flag using this command:

find "/Applications/iTerm.app" -exec xattr -r -d com.apple.quarantine {} \;

Replace "/Applications/iTerm.app" with the appropriate app name as needed, obviously.

You will need to re-launch the app for the app translocation to go away.

0

Although 5 months ago - did you ensure that there is no other iTerm2 application stored at your local machine except for the one in the application folder?

For example, if a different copy is still in the Download folder, then it might be called from there. Later the prompt appears to move it in the application folder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .