0

This question already has an answer here:

For the past 2-3 months, I am having a weird issue on my Macbook Air. I was hoping if someone here can help me out.

First, spotlight stopped searching on my mac. In the picture below, I am searching for Sublime app on my machine but it only shows results from the web. Spotlight Search

Second, search in outlook stopped working. No matter what I search, it always returned with no results found. In the image below, there should be many emails which has invoice in subject or body but it just shows no results.

Outlook Search

Finally today, search bar in Safari started behaving weirdly. Typing here used to bring in my bookmarks but they don't come up. Even the enter key doesn't work.

A lot of my productivity has been hampered by this. Does anyone have a suggestion? Thank you.

[Edit] The issue for safari was resolved after I restarted my mac.

marked as duplicate by Mark, IconDaemon, n1000, Nimesh Neema, Community Apr 25 at 14:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This doesn't look like iOS, it's macOS. Please update your title. There's a few similar questions here about Spotlight searches and results. Have you looked at those answers and tried them yet? Those would be the starting point for any troubleshooting. – fsb Apr 25 at 12:17
  • Looks like different issues with no common cause. For Spotlight, go to System Preferences → Spotlight and see if the appropriate categories are selected. You should also consider rebuilding Spotlight index. Search not working in Outlook and Safari are independent from Spotlight IMO. – Nimesh Neema Apr 25 at 12:19
  • @fsb Thank you. I have updated the title. It was my bad. – RajeshShah Apr 25 at 12:21
  • @NimeshNeema The issue for Outlook and Spotlight happened on the same date so I believe they are related in someway. I did look at rebuilding the spotlight search but it didn't work. I will give it another try today. – RajeshShah Apr 25 at 12:22
  • 2
    I'm voting to close this question as off-topic because this is a temporary issue that cannot be reproduced and was fuxed with a reboot. Question is not useful to anyone in the future. – Mark Apr 25 at 13:26

Browse other questions tagged .