3

When I go into the App Store and hit update, or try to download a new game, I get the prompt shown in the image.

I hit OK, and it loads the Terms and Conditions just fine and there is a nice blue accept button that I hit in the top right. However upon doing so it take me back to the App Store where I was before and then after about 1-2 seconds the prompt to accept reappears. Telling me to accept these Terms and Conditions.

I think the issue has something to do with the fact I had to change my region for the App Store recently as prior to that I had no issue with this. I needed an app from a foreign App Store to make travelling on public transport easier. And now I’ve switch back to the United Kingdom’s App Store. All of these apps that need updating were downloaded while I have been on the UK AppStore previously. And even games I’ve never downloaded before give me the prompt.

I also tried changing regions again and back, but to no avail. I’ve tried reading the whole Terms and conditions again and emailing them to myself. And I’m just about out of ideas.

  • this problem has occurred to many iPhone, iPad users around the world. So i think it's app store error. We should wait for fix. I Have same problem too – Sambuu Apr 25 at 7:17
  • An update has been shared by TechCrunch. I have edited the answer to mention the same. – Nimesh Neema Apr 26 at 8:18
3

Important Update

As noted in the below linked 9to5Mac article, an updated has been shared by TechCrunch:

Update: TechCrunch has now reported that Apple has “deployed a fix” and the bug should be resolved “in a matter of hours” as the patch is rolled out. The fix is being applied server-side, so users won’t need to make any changes to see the problem resolved.


Originally Posted Answer

This is apparently an issue currently with the App Store which is affecting a large number of users and is also affecting Apple's own servers. It is widely reported.

Some sizeable number of people are experiencing an issue with the App Store at the moment. On an affected account, when attempting to download a pending app update or a whole new app, users are presented with a dialog to accept new Apple Media Services Terms & Conditions.

and

A number of iPhone and iPad users this morning are taking to Twitter and Reddit to report an issue with the App Store that prevents them from downloading or updating apps.

The problem starts when a user taps the Get button on an app listing, whereupon a pop-up informs them that "Apple Media Services Terms and Conditions have changed" and that they must read and accept them to continue.

According to the article, some users were able to circumvent the issue as follows:

Some users report that simply tapping Cancel when the T&C notification first pops up makes it go away, allowing them to download or update the app in question.

Since it's a widely reported issue, it's very likely that a fix will be made for the same. You can try the aforementioned, or wait for some time to have the fix available.

You can also consider getting in touch with Apple support via their support channels:

Do note that contacting support is crucial here. Even if the contact personnel is not able to provide you a solution instantly, with enough number of requests going to Apple Support, they become aware of the gravity of issue and will work on fixing it soon.

You must log in to answer this question.

protected by Community Apr 25 at 20:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .