8

I need to download the macOS 10.12 SDK to build and run ispwDownloader (because there were no built downloads).

How can I download and install the SDK? Searching the Web has not been helpful with the solution.

11

@Nimesh Neema, the SDKs are stored in /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/, and I got the 10.12 SDK from here.

It works.

5
  • I wasn't aware that you posted this answer addressing me. I get to know about it just by chance while viewing this question again. This should ideally have been mentioned as a comment to my answer. Kindly consider moving it there and delete this answer. And BTW, did your approach work?
    – Nimesh Neema
    May 1 '19 at 16:57
  • Hi Sam - it’s fine to turn this into an answer with an edit or just delete it if you don’t have an answer to provide.
    – bmike
    May 1 '19 at 17:23
  • @NimeshNeema sorry about that, and yes it did.
    – Sam
    May 1 '19 at 17:56
  • My current macOS catalina 10.15.5 app store provided xcode 11.5 install has a /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/ folder with MacOSX.sdk folder in it and a symbolic link folder MacOSX10.15.sdk pointing to that MacOSX.sdk folder. If I download 10.12 sdk into a MacOSX10.12.sdk folder in path do i need to change anything about the existing folders for an xcode project expecting access to 10.12 sdk to find it?
    – myusrn
    Jun 30 '20 at 20:24
  • You shouldn’t have to change anything, as long as you specify inside of the projects that they should use the 10.12 SDK
    – Sam
    Jun 30 '20 at 23:12
1

You'll have to download and run the compatible version of Xcode which included macOS 10.12 SDK, on compatible version of macOS.

Refer to the Xcode version comparison table on Xcode - Wikipedia article.

macOS 10.12 SDK was first introduced in Xcode 8.0. The last macOS 10.12 SDK was macOS 10.12.4 SDK which was released with Xcode 8.3. Xcode 8.3 saw three bug fix releases with the last one being Xcode 8.3.3.

You'll need to download both the desired version of Xcode, and the compatible release of macOS which can run the said Xcode release. The information can be obtained from the linked table.

You can download Xcode 8.3.3 from Apple Developer downloads. Here's the direct link for the download. You may need to login with your Apple ID to initiate the download.

To run Xcode 8.3.3 you'll need either macOS Sierra 10.12 or macOS High Sierra 10.13. The latest release for them can be downloaded from the Mac App Store.

2
  • So I can't use Xcode 9?
    – Sam
    Apr 26 '19 at 17:12
  • Xcode 9 comes with macOS 10.13 SDK (refer to the table). The simplest approach is to download and use the Xcode version as mentioned in the table. (I don't know if it's possible to separately download specific macOS SDK and integrate it with specific version of Xcode.)
    – Nimesh Neema
    Apr 26 '19 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .