0

I have observed that when I add an email contact to my Gmail account, it also shows up in my iPhone contacts list. I don’t want email contacts under my iPhone contacts unless I have a phone number. I don’t know if iPhone is saving them or if it is something Google is doing.

I do know that no matter what I try, delete, toggle various things off or on nothing stops this. If I delete from iPhone, it also deletes the email address in my Gmail account. If I add the contact back to my Gmail account, it is also back in my iPhone contacts. I even tried hiding the Gmail stuff in iPhone contacts, and as soon as I put the email address in Gmail it was back in Contacts again.

This is beyond ridiculous. I can’t control my own contacts list. Everything I have seen in Google for help/search is old. Even the stuff from 2017 is no use.

  • I assume you have contacts and calendar OFF in Settings > Passwords & Accounts > Accounts > Gmail? It's good to be specific about exactly what settings you have on and off. – Steve Chambers Apr 24 at 22:11
  • I do. Honestly there are so many things I have turned on and off I have a difficult time remembering what they are. What I have found is that the different fixes I have seen apply to older iOS versions because the things they wanted done in Settings just weren’t there. – user330316 Apr 26 at 3:36

You must log in to answer this question.