0

I downloaded Signal desktop app from this URL:

However, when attempting to extract the zip archive using unzip command, this is what I get:

~/Downloads$ unzip signal-desktop-mac-1.24.1.zip 
Archive:  signal-desktop-mac-1.24.1.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of signal-desktop-mac-1.24.1.zip or
        signal-desktop-mac-1.24.1.zip.zip, and cannot find signal-desktop-mac-1.24.1.zip.ZIP, period.

Should be pretty straightforward. I don't know what the problem is. unzip -t also fails with the same error.

I've tried to download this several times. Same problem. Also happens with signal-desktop-mac-1.23.2.zip. I doubt the archive is corrupted across several versions, and my system has no other known problems.

3
  • 1
    How about double clicking in Finder to extract? I just gave it a try and was able to extract the Signal.app bundle successfully.
    – Nimesh Neema
    Apr 24 '19 at 16:40
  • Downloaded to my Downloads folder and double-clicked Signal app is the result.
    – Solar Mike
    Apr 24 '19 at 16:45
  • I downloaded the link and when I went to the download folders the Signal.app was already extracted.
    – Natsfan
    Apr 24 '19 at 16:47
1

Running

file signal-desktop-mac-1.24.1.zip

in the Terminal outputs:

signal-desktop-mac-1.24.1.zip: Zip archive data, at least v?[0x314] to extract

indicating that there's some issue with how the zip file is encoded. That explains why unzip may have failed to extract the files from the compressed archive.

However, when attempting to extract via built-in Archive Utility by double clicking, or right clicking and selecting Open, the archive extracts successfully.

I tried it, successfully extracted Signal.app and was able to run it.

5
  • FWIW file signal-desktop-mac-1.24.1.zip for me returns signal-desktop-mac-1.24.1.zip: Zip archive data, at least v2.0 to extract; however, unzip, and or other installed third-party archiving utilities, except for the default macOS Archive Utility.app fail with the same/similar error message. Apr 24 '19 at 16:57
  • @user3439894 That's weird. Can you check the md5 checksum for the downloaded zip archive? Running md5 signal-desktop-mac-1.24.1.zip on my system returns MD5 (signal-desktop-mac-1.24.1.zip) = 9556d48451cb93b909afb443bf456a44.
    – Nimesh Neema
    Apr 24 '19 at 16:59
  • MD5(signal-desktop-mac-1.24.1.zip)= 9556d48451cb93b909afb443bf456a44 BTW This is on macOS High Sierra. Apr 24 '19 at 17:00
  • @user3439894 I am running macOS Mojave 10.14.4. Running unzip -v returns UnZip 6.00 of 20 April 2009, by Info-ZIP. and Compiled with gcc 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.37.14) for Unix Mac OS X on Feb 22 2019.
    – Nimesh Neema
    Apr 24 '19 at 17:04
  • For me, running unzip -v returns UnZip 6.00 of 20 April 2009, by Info-ZIP. Compiled with gcc 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.31) for Unix Mac OS X on Oct 6 2017. --- Regardless of the differences, the only thing in common so far that works is the macOS default Archive Utility.app. Apr 24 '19 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .