1

when I press delta key a ˜ instead of ~, I have to hit space every time after printing ˜ to get ~.

How to print ~ directly without clicking space after it?

my system is Mojave 10.14.4 my keyboard is U.S. International - PC

3

Get rid of “us international pc” and use “us”or “abc” instead. You do this in system preferences/keyboard/input sources.

  • Former settings were trying to enter a tilde, to be placed as an accent mark over the next letter typed (e.g. ˜ + n = ñ). Changing key mapping corrected this to intended behavior. (on default US layout, ~ is a dedicated key, whereas ˜ requires option+n) – dr.nixon Apr 25 at 21:52
  • @dr.nixon yes, US International PC is a special mapping, taken over by Apple from Windows, in which 5 characters -- ` ~ ^ " ' -- become deadkeys to facilitate making accented characters used in common W. European languages. I think users sometimes choose it by mistake, thinking it is required for the "English International" hardware keyboard. – Tom Gewecke Apr 25 at 22:16
  • Personally, I find that weird, because macOS already makes it dead easy to add these characters; n ` e u i plus option key map to ˜ ` ´ ¨ ˆ respectively - the next letter pressed has the accent assigned, so you can quickly type ñ, è, é, ö, î , etc. Every time I switch back to my work-provided Windows machine I am annoyed at how awkward character entry is there. I agree that choice of US International keyboard layout was likely made by a user out of habit or unaware that macOS has this functionality built into the standard layout already. – dr.nixon Apr 25 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .