2

I don't know what happened. I restarted mac and since then I don't have top right icons: network, sound, battery, clock, notification but from time to time it blink and for a moment become visible but immediately disappear. I tried (and with sudo):

killall -KILL SystemUIServer
No matching processes belonging to you were found

I restarted mac and still same. Is there any way that I can reset this icons settings? And I repeat wired thing is that it blink as I move cursor and from time to time for a moment I see items. And also skype, dropbox and spotlight icons are always there.

1

The following approach is suggested:

  1. Navigate to the Library folder in Finder
  • Open Finder
  • Use Go -> Go to Folder (Shortcut: Cmd+Shift+G)
  • Type ~/Library and hit Go

Go to the folder menu

  1. From the Library, navigate to the Preferences folder.
    • Locate and remove the file named com.apple.systemuiserver.plist

Library - Preferences in Finder

  1. Navigate to the folder ByHost which is inside the Preferences folder.
    • Locate and remove the file(s) named com.apple.systemuiserver.[random_number].plist
  2. Restart your computer.

SystemUIServers handles .menu software amongst other things, and thus this is expected to resolve your issue.

9
  • 2
    I don't have com.apple.systemuiserver.plist in that folder. Also there is no ByHost folder. – 1110 Apr 24 '19 at 14:21
  • First, look for the file in ~/Library instead Alternatively, (1) Reboot into Safe Mode, and back again. (2) Recover/restore the com.apple.systemuiserver.plist from a Time Machine backup. (3) See if the file appears when using ls -lO ~/Library/Preferences/com.apple.s*.plist – Nerolite Apr 24 '19 at 15:03
  • See Ask Different - Com.apple.finder.plist is missing and isn't being made automatically for additional info. Remember the tilde in ~/Library. – Nerolite Apr 25 '19 at 7:07
  • 1
    I tried and didn't work. I boot into safe mode and issue is there in safe mode too. I restarted still same. When I enter that command it is listed. I deleted files from ~/Library I don't know what is this – 1110 Apr 25 '19 at 11:21
  • 1
    Yes. I did all that restarted problem was still there. Then I reboot to safe mode and restart and everything same. When I am on user pick screen items are there but when login they disappear (all users). – 1110 Apr 25 '19 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .